summaryrefslogtreecommitdiff
path: root/dev-python/flask-admin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/flask-admin
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/flask-admin')
-rw-r--r--dev-python/flask-admin/Manifest7
-rw-r--r--dev-python/flask-admin/flask-admin-1.0.6.ebuild46
-rw-r--r--dev-python/flask-admin/flask-admin-1.5.0.ebuild58
-rw-r--r--dev-python/flask-admin/flask-admin-1.5.1.ebuild58
-rw-r--r--dev-python/flask-admin/metadata.xml11
5 files changed, 180 insertions, 0 deletions
diff --git a/dev-python/flask-admin/Manifest b/dev-python/flask-admin/Manifest
new file mode 100644
index 000000000000..7880714c3d8e
--- /dev/null
+++ b/dev-python/flask-admin/Manifest
@@ -0,0 +1,7 @@
+DIST Flask-Admin-1.0.6.tar.gz 235842 BLAKE2B d0c2d48076d8c5d6f5df4b779128d1b9ecf00d8a6ef01df1d39a75212dc99f08a4ba7d03a95c8f39c4b3442ae4651d7185bf3faf528804f78f46277dd18dc3e2 SHA512 a30e2678a063d45d55ccf41cfec07fd16973cc8c770b1e7f16d11b9aba693049b1d9d4cff81d8ae8f2548d019f977f0906728e98d23d229d76bf135a079abc8f
+DIST Flask-Admin-1.5.0.tar.gz 1598074 BLAKE2B a7ca1fab32621cacfcf691f779e88e134369be82f1904db02f72cd51fbbdfecb22b9da06800a9cfae99336ed2807914a6420248c43775c9ec37d65ce242ce17c SHA512 dbf5b97f27228eb000fd1298f4da8d4824196856e4ba9e2d8cbae6e562794ec2d1a998b382efaa84ec4fd7a74ae589a739c52e117efebfb171f19bc16e7350e7
+DIST Flask-Admin-1.5.1.tar.gz 1587527 BLAKE2B e734284d3adb7380b71df3718910977c49f76c7e561991c969b8e85952cd3963ede0e1e039c8dcb7c512c00851f1968a9c6e011ad1a064dd8fe4d00390581c31 SHA512 00e31f126048321114e422fda4a0ec84b5caa1a0c03afa17fc6a7078a3f99f843c2688b07462bae283533d52a575935dbab2ce6b731b1d1c3a1e93f315e37de3
+EBUILD flask-admin-1.0.6.ebuild 1184 BLAKE2B d207f625927fb81569924d6637f67d1492922b0550d2700c3f0342da0b9504559bd26d65ff44af4a144b4cc2b825d4a3bf1fef4ce4d5e897d1802b6c1c4519e1 SHA512 6be0333027aec3c0c35922bbdf8bad26236377c688ac42f40f3792d7006e1e5444c662f50990334b94b3ed5d024f12de3f84de4dac99bb9b3cc93ffef7cb24e8
+EBUILD flask-admin-1.5.0.ebuild 1558 BLAKE2B 0772248241acef99af60fa088eea9d2e2740284b2aa9363d9e58e5514138e550e0923f13efd2f27208c98f1d572287a43d26d0cfdf5bf664f60e78bcf34bf114 SHA512 273cb92cd77795d8831a5fd06c17e8852e79ef156c1ef0c5fc846c582c7e6c813640c172014699beff18380112f1137f2218da1af30966fb61b7ede9902cc91b
+EBUILD flask-admin-1.5.1.ebuild 1560 BLAKE2B 79d2c4244e748513510c09959e460bf78af67b4161b742fec886313b6ed6757e8393281fc5c4925cd71b542d8e0486344e14fa31d767b52d74ba1b4f40066228 SHA512 1b9fddde0fec770ee9e3cec6e241fb6a0df66806b752dca20fec566b588bb83a6b61b8efbb9e996e253aa02faf5237911b8ac80c8e1f2f87ab513f156d355b6c
+MISC metadata.xml 324 BLAKE2B 55c4107d89499162e5db7cb618a5d0214fec80c6780bebcdcdf2fdecad7b12163e5e405935e1bdb1f37d687e23ccb72b4f9d2440b6bec1b906b0057fda96e9ef SHA512 02944086c5f7fbcc10241e5596db8caef60c142ddfcc28627c9e7bbe9b472663fc6be2f6234d0205233c7ab5e51b9a4a1c4f7f08256daf1314ae3f0274469ff8
diff --git a/dev-python/flask-admin/flask-admin-1.0.6.ebuild b/dev-python/flask-admin/flask-admin-1.0.6.ebuild
new file mode 100644
index 000000000000..8433ca9aadab
--- /dev/null
+++ b/dev-python/flask-admin/flask-admin-1.0.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+#RESTRICT="test" # we're still missing some of the dependencies
+
+MY_PN="Flask-Admin"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Simple and extensible admin interface framework for Flask"
+HOMEPAGE="https://pypi.org/project/Flask-Admin/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/flask-wtf[${PYTHON_USEDEP}]
+ dev-python/flask-pymongo[${PYTHON_USEDEP}]
+ dev-python/flask-peewee[${PYTHON_USEDEP}]
+ dev-python/flask-mongoengine[${PYTHON_USEDEP}]
+ dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ sed \
+ -e 's:find_packages():find_packages(exclude=["*.examples", "*.examples.*", "examples.*", "examples"]):g' \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests || die "Testing failed with ${EPYTHON}"
+}
diff --git a/dev-python/flask-admin/flask-admin-1.5.0.ebuild b/dev-python/flask-admin/flask-admin-1.5.0.ebuild
new file mode 100644
index 000000000000..f372d0b52f38
--- /dev/null
+++ b/dev-python/flask-admin/flask-admin-1.5.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+#RESTRICT="test" # we're still missing some of the dependencies
+
+MY_PN="Flask-Admin"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Simple and extensible admin interface framework for Flask"
+HOMEPAGE="https://pypi.org/project/Flask-Admin/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND="
+ >=dev-python/flask-0.7[${PYTHON_USEDEP}]
+ dev-python/wtforms[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/flask-wtf[${PYTHON_USEDEP}]
+ dev-python/peewee[${PYTHON_USEDEP}]
+ dev-python/wtf-peewee[${PYTHON_USEDEP}]
+ dev-python/flask-pymongo[${PYTHON_USEDEP}]
+ dev-python/flask-mongoengine[${PYTHON_USEDEP}]
+ dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/flask-babelex[${PYTHON_USEDEP}]
+ sci-libs/Shapely[${PYTHON_USEDEP}]
+ dev-python/geoalchemy2[${PYTHON_USEDEP}]
+ >=dev-python/pillow-2.9[${PYTHON_USEDEP},jpeg(+)]
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ sed \
+ -e 's:find_packages():find_packages(exclude=["*.examples", "*.examples.*", "examples.*", "examples"]):g' \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/flask-admin/flask-admin-1.5.1.ebuild b/dev-python/flask-admin/flask-admin-1.5.1.ebuild
new file mode 100644
index 000000000000..92f63bd3eddb
--- /dev/null
+++ b/dev-python/flask-admin/flask-admin-1.5.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+#RESTRICT="test" # we're still missing some of the dependencies
+
+MY_PN="Flask-Admin"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Simple and extensible admin interface framework for Flask"
+HOMEPAGE="https://pypi.org/project/Flask-Admin/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="examples test"
+
+RDEPEND="
+ >=dev-python/flask-0.7[${PYTHON_USEDEP}]
+ dev-python/wtforms[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/flask-wtf[${PYTHON_USEDEP}]
+ dev-python/peewee[${PYTHON_USEDEP}]
+ dev-python/wtf-peewee[${PYTHON_USEDEP}]
+ dev-python/flask-pymongo[${PYTHON_USEDEP}]
+ dev-python/flask-mongoengine[${PYTHON_USEDEP}]
+ dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/flask-babelex[${PYTHON_USEDEP}]
+ sci-libs/Shapely[${PYTHON_USEDEP}]
+ dev-python/geoalchemy2[${PYTHON_USEDEP}]
+ >=dev-python/pillow-2.9[${PYTHON_USEDEP},jpeg(+)]
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ sed \
+ -e 's:find_packages():find_packages(exclude=["*.examples", "*.examples.*", "examples.*", "examples"]):g' \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/flask-admin/metadata.xml b/dev-python/flask-admin/metadata.xml
new file mode 100644
index 000000000000..282f7b064249
--- /dev/null
+++ b/dev-python/flask-admin/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">Flask-Admin</remote-id>
+ </upstream>
+</pkgmetadata>