summaryrefslogtreecommitdiff
path: root/dev-python/django-registration/django-registration-3.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-31 17:46:47 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-31 17:46:47 +0000
commit027dc9b3977cd14e0c7ae52e7bf9370c3919afa1 (patch)
tree2e6c00a5d825e5224d67f2a4309d576d722b8a8b /dev-python/django-registration/django-registration-3.4-r1.ebuild
parent0f7bcc64cee796c21b0ea6af6e171e89fd33966e (diff)
gentoo auto-resync : 31:12:2023 - 17:46:47
Diffstat (limited to 'dev-python/django-registration/django-registration-3.4-r1.ebuild')
-rw-r--r--dev-python/django-registration/django-registration-3.4-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/django-registration/django-registration-3.4-r1.ebuild b/dev-python/django-registration/django-registration-3.4-r1.ebuild
new file mode 100644
index 000000000000..32821af1079c
--- /dev/null
+++ b/dev-python/django-registration/django-registration-3.4-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1
+
+DESCRIPTION="user-registration application for Django"
+HOMEPAGE="
+ https://pypi.org/project/django-registration/
+ https://github.com/ubernostrum/django-registration/
+"
+SRC_URI="
+ https://github.com/ubernostrum/${PN}/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/confusable_homoglyphs[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ local -x DJANGO_SETTINGS_MODULE=tests.settings
+ PYTHONPATH=. "${EPYTHON}" runtests.py || die "Tests failed with ${EPYTHON}"
+}