summaryrefslogtreecommitdiff
path: root/dev-python/defusedxml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/defusedxml
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/defusedxml')
-rw-r--r--dev-python/defusedxml/Manifest3
-rw-r--r--dev-python/defusedxml/defusedxml-0.5.0.ebuild29
-rw-r--r--dev-python/defusedxml/metadata.xml12
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/defusedxml/Manifest b/dev-python/defusedxml/Manifest
new file mode 100644
index 000000000000..1e0aaa09a181
--- /dev/null
+++ b/dev-python/defusedxml/Manifest
@@ -0,0 +1,3 @@
+DIST defusedxml-0.5.0.tar.gz 60405 BLAKE2B bd57b3b705abff71ff99ce4e43fe4c1fd708463546cc5d614dceb56f36e98771ef5c952a1aae010d32e4b557ed687c194c61723a0b3334dc1b0d517591d7c3d3 SHA512 71e1a604df9be41ded454bcdfa63610e897eb405295d7365fcddfc5f50f7572c36f0bd91a4a1fdf47d1b097637bd9fdcf08f1cdb73e2fe64eea0320a7532e452
+EBUILD defusedxml-0.5.0.ebuild 747 BLAKE2B ab1b62fe074534248d7f87eaf3e25302d729231ccebf5f078a411e69eb59f35a2a11ecd3ab26ef55f62ef1f72f7ab00360f127848176f40061ebe0fcd055f264 SHA512 7dbfb1dd6ed987949868ba4a1383313c540ab21772648b3f7da48c5b2f6944a8934e0b411aea3f78abf0e1176f2a879d785a4bd4b1ea4106f416610e809d4750
+MISC metadata.xml 384 BLAKE2B 27ce5f8830ff4e0646f95d633cbaeb85576ec01fea3bb46d7b54d2be2acd6f154ccfe8455169d61014bce03e5434eb449c2876c53a77f64bf083559985531de7 SHA512 377bdeac0f80c45f6f6f3387182e75c47e8cd526f563a1ce5305119113b4a1c4a99dc3a76bc91d81a967498645c9a23dc2746b62023dd0dc26e8d55d15424b6c
diff --git a/dev-python/defusedxml/defusedxml-0.5.0.ebuild b/dev-python/defusedxml/defusedxml-0.5.0.ebuild
new file mode 100644
index 000000000000..8fb69ae23f7f
--- /dev/null
+++ b/dev-python/defusedxml/defusedxml-0.5.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="XML bomb protection for Python stdlib modules, an xml serialiser"
+HOMEPAGE="https://bitbucket.org/tiran/defusedxml https://pypi.org/project/defusedxml/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd"
+IUSE="examples"
+
+LICENSE="PSF-2"
+SLOT="0"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( other/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/defusedxml/metadata.xml b/dev-python/defusedxml/metadata.xml
new file mode 100644
index 000000000000..3d589eb07db0
--- /dev/null
+++ b/dev-python/defusedxml/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">defusedxml</remote-id>
+ <remote-id type="bitbucket">tiran/defusedxml</remote-id>
+ </upstream>
+</pkgmetadata>