summaryrefslogtreecommitdiff
path: root/dev-python/boltons
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-18 00:29:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-18 00:29:05 +0000
commit467e2131896a3030032cd5b0fab2094a045bf9d0 (patch)
tree534578ca7ef61b3eb30fee861db78c0ae58e2fa6 /dev-python/boltons
parent1f254b1ee917690b4f8f7738fdcfc295ee304ff7 (diff)
gentoo auto-resync : 18:03:2023 - 00:29:05
Diffstat (limited to 'dev-python/boltons')
-rw-r--r--dev-python/boltons/Manifest2
-rw-r--r--dev-python/boltons/files/boltons-21.0.0-python3.10.patch110
-rw-r--r--dev-python/boltons/files/boltons-21.0.0-python3.11-tests.patch7
3 files changed, 0 insertions, 119 deletions
diff --git a/dev-python/boltons/Manifest b/dev-python/boltons/Manifest
index 36414afd203d..17aa3bfbe8fc 100644
--- a/dev-python/boltons/Manifest
+++ b/dev-python/boltons/Manifest
@@ -1,5 +1,3 @@
-AUX boltons-21.0.0-python3.10.patch 3393 BLAKE2B 24d9bf2368a0716332e85222fcf8965b9633aa26967e9f9bac6f5ee31fbd8aa71dc2e24bfeeaa6ad766511f8f09a68a1b4288fa66b9ab7ec58f1e01453d5adae SHA512 3db60c0a2cd8680fc58151ad788838b6d795c16b5162326382aba883a7fe86a294cc1d490d40ff40ecd3eecb37e518c85bee0c67910938e8d3623f0dc5f6d6df
-AUX boltons-21.0.0-python3.11-tests.patch 267 BLAKE2B 03af16f7f058094369f97aa4753833cfd43a0f0da7dbb6a423b3e4fb8b4f52692d993f22449232d8653075f1031d07a25d4a3a7f8d71268d62ba8a62562a1b81 SHA512 de99f35ed56c50122b531a9750225d5135d1b429fdb4a8312d04e4c1cb9cfffeaeec08fa718223d3e1952656f40dfb0698f40c855d09e9db63832c5be0ddcc04
DIST boltons-23.0.0.gh.tar.gz 243426 BLAKE2B 94913e31611d844404df9514e3449ec8142c142c3e3fc223d912a5e6ab22e5a502ebf1594e3ea9143eb57d80745e34d5e19080bb24e1ad9b42b52cc544c608d4 SHA512 f8e2ed488dbdf0dfa4090aac8c6ee97c382fdf8a2728567e2a5542f46bb00932f3b9498865d45a718216d5f9355e419a228c624844c25f89df458e00bc9e2e83
EBUILD boltons-23.0.0.ebuild 820 BLAKE2B 5850d1dee9fe56b856ad668d12d21839e703c8c2ee32dc1cb08094034ae77fd18af845e7101498b189f552d8d5503a38e32be40c8f08ecd3ef19e1861c3a2059 SHA512 049b49826a74d57d8c2dfb78c06af2c93d2652f22818ec9e287fccbebfab387099f76bd6ed233d78f6a7efd2f48b421f68d55d9c43c04fdf42634d978d544bfb
MISC metadata.xml 395 BLAKE2B 6ed304f1dced75dfd795b9fe582ec669bf1c8ba5fefeb9e753b11aa20de8fc0966fc9a8a0ed40e460dd23a67ef0e5721a8dae27b3d799a4be629537bb18f54c9 SHA512 fb73041a95df230153dc686e21a88d91bb06367ae8c22a20777c4a0f13202cbaf59396f4ed2630265d331d6461a6da85f57ba62cc432c4d9105b8404753b383b
diff --git a/dev-python/boltons/files/boltons-21.0.0-python3.10.patch b/dev-python/boltons/files/boltons-21.0.0-python3.10.patch
deleted file mode 100644
index 2e9974a71c9e..000000000000
--- a/dev-python/boltons/files/boltons-21.0.0-python3.10.patch
+++ /dev/null
@@ -1,110 +0,0 @@
-https://github.com/mahmoud/boltons/commit/270e974
-From: Mahmoud Hashemi <mahmoud@hatnote.com>
-Date: Sun, 10 Oct 2021 23:26:24 -0700
-Subject: [PATCH] address ecoutils import issue, fixes #294
---- a/boltons/ecoutils.py
-+++ b/boltons/ecoutils.py
-@@ -354,38 +354,53 @@ def get_profile(**kwargs):
- return ret
-
-
--_real_safe_repr = pprint._safe_repr
--
--
--def _fake_json_dumps(val, indent=2):
-- # never do this. this is a hack for Python 2.4. Python 2.5 added
-- # the json module for a reason.
-- def _fake_safe_repr(*a, **kw):
-- res, is_read, is_rec = _real_safe_repr(*a, **kw)
-- if res == 'None':
-- res = 'null'
-- if res == 'True':
-- res = 'true'
-- if res == 'False':
-- res = 'false'
-- if not (res.startswith("'") or res.startswith("u'")):
-- res = res
-- else:
-- if res.startswith('u'):
-- res = res[1:]
-+try:
-+ import json
-+
-+ def dumps(val, indent):
-+ if indent:
-+ return json.dumps(val, sort_keys=True, indent=indent)
-+ return json.dumps(val, sort_keys=True)
-+
-+except ImportError:
-+ _real_safe_repr = pprint._safe_repr
-+
-+ def _fake_json_dumps(val, indent=2):
-+ # never do this. this is a hack for Python 2.4. Python 2.5 added
-+ # the json module for a reason.
-+ def _fake_safe_repr(*a, **kw):
-+ res, is_read, is_rec = _real_safe_repr(*a, **kw)
-+ if res == 'None':
-+ res = 'null'
-+ if res == 'True':
-+ res = 'true'
-+ if res == 'False':
-+ res = 'false'
-+ if not (res.startswith("'") or res.startswith("u'")):
-+ res = res
-+ else:
-+ if res.startswith('u'):
-+ res = res[1:]
-
-- contents = res[1:-1]
-- contents = contents.replace('"', '').replace(r'\"', '')
-- res = '"' + contents + '"'
-- return res, is_read, is_rec
-+ contents = res[1:-1]
-+ contents = contents.replace('"', '').replace(r'\"', '')
-+ res = '"' + contents + '"'
-+ return res, is_read, is_rec
-
-- pprint._safe_repr = _fake_safe_repr
-- try:
-- ret = pprint.pformat(val, indent=indent)
-- finally:
-- pprint._safe_repr = _real_safe_repr
-+ pprint._safe_repr = _fake_safe_repr
-+ try:
-+ ret = pprint.pformat(val, indent=indent)
-+ finally:
-+ pprint._safe_repr = _real_safe_repr
-+
-+ return ret
-+
-+ def dumps(val, indent):
-+ ret = _fake_json_dumps(val, indent=indent)
-+ if not indent:
-+ ret = re.sub(r'\n\s*', ' ', ret)
-+ return ret
-
-- return ret
-
-
- def get_profile_json(indent=False):
-@@ -393,20 +408,6 @@ def get_profile_json(indent=False):
- indent = 2
- else:
- indent = 0
-- try:
-- import json
--
-- def dumps(val, indent):
-- if indent:
-- return json.dumps(val, sort_keys=True, indent=indent)
-- return json.dumps(val, sort_keys=True)
--
-- except ImportError:
-- def dumps(val, indent):
-- ret = _fake_json_dumps(val, indent=indent)
-- if not indent:
-- ret = re.sub(r'\n\s*', ' ', ret)
-- return ret
-
- data_dict = get_profile()
- return dumps(data_dict, indent)
diff --git a/dev-python/boltons/files/boltons-21.0.0-python3.11-tests.patch b/dev-python/boltons/files/boltons-21.0.0-python3.11-tests.patch
deleted file mode 100644
index a54b2a4d0cf1..000000000000
--- a/dev-python/boltons/files/boltons-21.0.0-python3.11-tests.patch
+++ /dev/null
@@ -1,7 +0,0 @@
-object.__getstate__ was added in 3.11 (bpo-26579) and the test is unaware
---- a/tests/test_dictutils.py
-+++ b/tests/test_dictutils.py
-@@ -476,2 +476,3 @@
- '__getitem__',
-+ '__getstate__',
- '__gt__',