summaryrefslogtreecommitdiff
path: root/dev-php/symfony-dependency-injection
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
commit121ed4eec41fbf03e1998d09eede1bf449da63b9 (patch)
treece9341d77d1507f67d4a3a1472da9011b5baa0a8 /dev-php/symfony-dependency-injection
parentdd762ff83c330186ee2ede002e08b2f780cddd51 (diff)
gentoo resync : 19.07.2019
Diffstat (limited to 'dev-php/symfony-dependency-injection')
-rw-r--r--dev-php/symfony-dependency-injection/Manifest2
-rw-r--r--dev-php/symfony-dependency-injection/symfony-dependency-injection-2.8.50.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-php/symfony-dependency-injection/Manifest b/dev-php/symfony-dependency-injection/Manifest
index 84c864203d32..3de28a506af2 100644
--- a/dev-php/symfony-dependency-injection/Manifest
+++ b/dev-php/symfony-dependency-injection/Manifest
@@ -1,4 +1,6 @@
AUX autoload.php 518 BLAKE2B c30fc902cb212ea271a76bb5dfd4b5292c68c483a3e37403c2ed305d0338bc4d8c94c6368108b29e07170c962475448e12806277690c033ece159279b35825a1 SHA512 eefcab891547ce99a3ec9b11f7e4edb5de3164958fa5c698d64411c0a2c1a72711d94fda4e32ceb4fec6b7d2f83f159d4f80bbc3719c18895708652af2b5e377
DIST symfony-dependency-injection-2.8.20.tar.gz 117123 BLAKE2B 469b11d55bbfdffe46b5cc94592f0bf81c1ddf82c656bbf9914a78cb7e5164960455c2ef1a70ef905b35775e91e279693af19015e586ddb3c95a0184d1737f32 SHA512 9ab6a4b36fde3908f26c2211066df501dd73387a7ec3d0aae85f8289257653bb54393bd9f4b50c347a4d5ba47214f13c089e475eaace3868f5c18f67b69bd829
+DIST symfony-dependency-injection-2.8.50.tar.gz 117771 BLAKE2B b71535619a45a03640064b987a7b5996dc991458c737661a983782d7af53bf89865bf511dbac99384f8ece583b628a2cde0def2cdd3e8c133055d84d9dbed1e1 SHA512 690b3f373c2fb549115f7fdb35880a2c94bf7afa28be2c75d718373e8925897f89d5e34f82b709b11cd8940547289345a8def4debe657f495a0b636a6aa72baa
EBUILD symfony-dependency-injection-2.8.20.ebuild 1225 BLAKE2B 0e86710dcd78ec76c9ad18e1cfdbde03f47c03b2cb81462ec15e6636515ede5fb1c2870fca93f79d23e356def7daba3946da61bbb7b3511074818447c6e7571d SHA512 0a356695ee5aba4ad3484447f091db58a1ad133fccfa00d4cae723516ec84fa153fa77ab4a05dc86dfea37dc6d9607c111647cba7178235ba1bb5d87441901b0
+EBUILD symfony-dependency-injection-2.8.50.ebuild 1224 BLAKE2B 017345586a3e9704ed645b02e8813ca986326af920b911ca8cd8d74d91bb524ed9f9a669c0bd51685160db977727381572266e83c2b279e1f4efb9e74295b826 SHA512 93906ac3db0ee4142966dd53957c71d46e6595d6a2ce8c1a3c5c8e707b99ebf82798e2c08faec0c6470a0e6f85ae17540e3cf73b2e6deb8336842802ef04a495
MISC metadata.xml 743 BLAKE2B 6b4332ed5a925353809cddc1b6136ec7f3f657039372b9ba7ea1e93285ecbfb780b09a7882f6b573a6d942eaa7a2ea1a6e0db1475dd9bc89efbc5171e7abd3ae SHA512 0a3cc149f3df429f4a6aa1e9941ffaa5969cd5f41444496ed120653e546fb240ee0afcefd44f984536c5bd48cfe867828ab6df5687b375163bb7aa7e3a05976c
diff --git a/dev-php/symfony-dependency-injection/symfony-dependency-injection-2.8.50.ebuild b/dev-php/symfony-dependency-injection/symfony-dependency-injection-2.8.50.ebuild
new file mode 100644
index 000000000000..e1ab01ad6686
--- /dev/null
+++ b/dev-php/symfony-dependency-injection/symfony-dependency-injection-2.8.50.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="Symfony DependencyInjection Component"
+HOMEPAGE="https://github.com/symfony/dependency-injection"
+SRC_URI="https://github.com/symfony/dependency-injection/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# The test suite requires the unpackaged symfony-expression-language.
+RESTRICT=test
+
+# I'm not sure if symfony-config and symfony-yaml are actually needed if
+# you're not running the test suite...
+RDEPEND="dev-lang/php:*
+ dev-php/fedora-autoloader
+ >=dev-php/symfony-config-2.1.0
+ >=dev-php/symfony-yaml-2.1.0"
+DEPEND="test? ( ${RDEPEND} >=dev-php/phpunit-5.7.15 )"
+
+S="${WORKDIR}/dependency-injection-${PV}"
+
+src_prepare() {
+ default
+ if use test; then
+ cp "${FILESDIR}/autoload.php" "${S}/autoload-test.php" || die
+ fi
+}
+
+src_install() {
+ insinto "/usr/share/php/Symfony/Component/DependencyInjection"
+ doins -r Compiler Dumper Exception Extension LazyProxy Loader ParameterBag
+ doins *.php "${FILESDIR}/autoload.php"
+ dodoc CHANGELOG.md README.md
+}
+
+src_test() {
+ phpunit --bootstrap "${S}/autoload-test.php" || die 'test suite failed'
+}