summaryrefslogtreecommitdiff
path: root/dev-perl/String-Formatter/String-Formatter-0.102.84.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/String-Formatter/String-Formatter-0.102.84.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/String-Formatter/String-Formatter-0.102.84.ebuild')
-rw-r--r--dev-perl/String-Formatter/String-Formatter-0.102.84.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/String-Formatter/String-Formatter-0.102.84.ebuild b/dev-perl/String-Formatter/String-Formatter-0.102.84.ebuild
new file mode 100644
index 000000000000..95ae12e03f97
--- /dev/null
+++ b/dev-perl/String-Formatter/String-Formatter-0.102.84.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=RJBS
+DIST_VERSION=0.102084
+inherit perl-module
+
+DESCRIPTION="build sprintf-like functions of your own"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/Params-Util
+ dev-perl/Sub-Exporter
+"
+DEPEND="
+ ${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.300.0
+ test? (
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"
+PERL_RM_FILES=(
+ "bench.pl" # https://github.com/rjbs/String-Formatter/issues/2
+)