summaryrefslogtreecommitdiff
path: root/dev-libs/libclsync
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/libclsync
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/libclsync')
-rw-r--r--dev-libs/libclsync/Manifest5
-rw-r--r--dev-libs/libclsync/libclsync-0.4.1.ebuild78
-rw-r--r--dev-libs/libclsync/libclsync-0.4.2.ebuild74
-rw-r--r--dev-libs/libclsync/metadata.xml19
4 files changed, 176 insertions, 0 deletions
diff --git a/dev-libs/libclsync/Manifest b/dev-libs/libclsync/Manifest
new file mode 100644
index 000000000000..035c6570a8db
--- /dev/null
+++ b/dev-libs/libclsync/Manifest
@@ -0,0 +1,5 @@
+DIST clsync-0.4.1.tar.gz 253890 BLAKE2B c8aada690635f1cac355a1eaa51f4379688b0005869c5dcd6edccf5ae8e86abddf9ff99ccfcffeb165ccc80f407087a3f0863d1b78279894ff410daf25467740 SHA512 875280f706026d44806b92c22fa58d016136b2792f67a6b7e77f932465081da7a1ebaf22c25e538e4b58bfe04cd1cd5450ecab99c3df53ddd2a0fa966442d444
+DIST clsync-0.4.2.tar.gz 256042 BLAKE2B 28474fc66341b93705a502fcff390e3affcd89a9e1eb272dce9b28be709562e09c03e9c300cfeb5371e2e618a2239468a58c46212a39d751fbbfddeaab12bcf6 SHA512 d14a2efc4bf58d9d5c7a3fe5634cacdd182cd7cd814b0e9ebd99024a7282b056d1f7ceeec6903666391c3572d599a18e205af818b098ed7768d5c0e0f4cd1200
+EBUILD libclsync-0.4.1.ebuild 1803 BLAKE2B 2a35a9a46b7cf9c9e9e4c9eed4f715b1efd9fb4dc026e0d879c41cb1adb973c0daaeda8a2b9c55579fcc0f95ec25b8c92cbbf74639744bdae92619702bb40d0d SHA512 a5e630dc4ebd513c6f979909ba70ca5f3da93c5bde173e37e8ab6c7e26e74242fcac3dcd8270bdc60129aa58301505e7dc7927312068e01960f9d259f3682be1
+EBUILD libclsync-0.4.2.ebuild 1705 BLAKE2B 4a16590f6a76d27d9f00b69c7c3f21cf75a7143d1588ce4fb62b049bc991553b30a43594a70e2be42ee5080538457feedb6c7eb9f9cfa34913725bfc85ffdd5c SHA512 76b97ae5b95133c8d3b1d89c18db94898069e737e72de492482b50e987ef71f161c21aa81cc9295d941a3d61b1a565229b16a4a74c3e87aea25206ed2a73e5a3
+MISC metadata.xml 718 BLAKE2B 30766db9a818c3dc8ed475fb0b885d20f6ff058eb2e493572923d9efa7708f29a8f9b91cb159a98e2683fbb268e8e44df7ea955098d574a4a707474abcb96e19 SHA512 4f5edc94ccb24487d3cf9f15dbc3c2e6666de4b22fdc8efe2daf10a2b9d31452d85cabe83403062383865d274aae826944da0756e2630af54b4055ac0fd87f64
diff --git a/dev-libs/libclsync/libclsync-0.4.1.ebuild b/dev-libs/libclsync/libclsync-0.4.1.ebuild
new file mode 100644
index 000000000000..ddfca4a6ff90
--- /dev/null
+++ b/dev-libs/libclsync/libclsync-0.4.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MY_PN=${PN#lib}
+MY_P="${MY_PN}-${PV}"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/xaionaro/${MY_PN}.git"
+else
+ SRC_URI="https://github.com/xaionaro/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+inherit autotools
+
+DESCRIPTION="Control and monitoring library for clsync"
+HOMEPAGE="http://ut.mephi.ru/oss/clsync https://github.com/xaionaro/clsync"
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="debug extra-debug extra-hardened hardened static-libs"
+REQUIRED_USE="
+ extra-debug? ( debug )
+ extra-hardened? ( hardened )
+"
+
+DEPEND="virtual/pkgconfig "
+RDEPEND="=app-doc/clsync-docs-0.4*"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ local harden_level=0
+ use hardened && harden_level=1
+ use extra-hardened && harden_level=2
+
+ local debug_level=0
+ use debug && debug_level=1
+ use extra-debug && debug_level=2
+
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --enable-socket-library \
+ --disable-clsync \
+ --enable-debug=${debug_level} \
+ --enable-paranoid=${harden_level} \
+ --without-bsm \
+ --without-kqueue \
+ --disable-capabilities \
+ --disable-cluster \
+ --enable-socket \
+ --disable-highload-locks \
+ --disable-unshare \
+ --disable-seccomp \
+ --without-libcgroup \
+ --without-gio \
+ --with-inotify=native \
+ --without-mhash
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ prune_libtool_files
+ use static-libs || find "${ED}" -name "*.a" -delete || die "failed to remove static libs"
+
+ # docs go into clsync-docs
+ rm -rf "${ED}/usr/share/doc" || die
+}
+
+pkg_postinst() {
+ einfo "clsync instances you are going to use _must_ be compiled"
+ einfo "with control-socket support"
+}
diff --git a/dev-libs/libclsync/libclsync-0.4.2.ebuild b/dev-libs/libclsync/libclsync-0.4.2.ebuild
new file mode 100644
index 000000000000..f685732c00eb
--- /dev/null
+++ b/dev-libs/libclsync/libclsync-0.4.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN=${PN#lib}
+MY_P="${MY_PN}-${PV}"
+
+inherit autotools eutils
+
+DESCRIPTION="Control and monitoring library for clsync"
+HOMEPAGE="http://ut.mephi.ru/oss/clsync https://github.com/xaionaro/clsync"
+SRC_URI="https://github.com/xaionaro/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug extra-debug extra-hardened hardened static-libs"
+S="${WORKDIR}/${MY_P}"
+
+REQUIRED_USE="
+ extra-debug? ( debug )
+ extra-hardened? ( hardened )
+"
+
+DEPEND="virtual/pkgconfig"
+RDEPEND="=app-doc/clsync-docs-0.4*"
+
+src_prepare() {
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ local harden_level=0
+ use hardened && harden_level=1
+ use extra-hardened && harden_level=2
+
+ local debug_level=0
+ use debug && debug_level=1
+ use extra-debug && debug_level=2
+
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --enable-socket-library \
+ --disable-clsync \
+ --enable-debug=${debug_level} \
+ --enable-paranoid=${harden_level} \
+ --without-bsm \
+ --without-kqueue \
+ --disable-capabilities \
+ --disable-cluster \
+ --enable-socket \
+ --disable-highload-locks \
+ --disable-unshare \
+ --disable-seccomp \
+ --without-libcgroup \
+ --without-gio \
+ --with-inotify=native \
+ --without-mhash
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ prune_libtool_files
+ use static-libs || find "${ED}" -name "*.a" -delete || die "failed to remove static libs"
+
+ # docs go into clsync-docs
+ rm -rf "${ED}/usr/share/doc" || die
+}
+
+pkg_postinst() {
+ einfo "clsync instances you are going to use _must_ be compiled"
+ einfo "with control-socket support"
+}
diff --git a/dev-libs/libclsync/metadata.xml b/dev-libs/libclsync/metadata.xml
new file mode 100644
index 000000000000..8c5ebe0c8bbd
--- /dev/null
+++ b/dev-libs/libclsync/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bircoph@gentoo.org</email>
+ <name>Andrew Savchenko</name>
+ </maintainer>
+ <longdescription>
+ Libclsync is a library for remote control and monitoring of
+ <pkg>app-admin/clsync</pkg> processes.
+</longdescription>
+ <use>
+ <flag name="extra-debug">Enable extra debugging. This will hurt performance badly. Be ready for tons of output.</flag>
+ <flag name="extra-hardened">Enable extra security checks. This may hurt performance.</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">xaionaro/clsync</remote-id>
+ </upstream>
+</pkgmetadata>