summaryrefslogtreecommitdiff
path: root/dev-java/icedtea-sound/icedtea-sound-1.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-java/icedtea-sound/icedtea-sound-1.0.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-java/icedtea-sound/icedtea-sound-1.0.1.ebuild')
-rw-r--r--dev-java/icedtea-sound/icedtea-sound-1.0.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-java/icedtea-sound/icedtea-sound-1.0.1.ebuild b/dev-java/icedtea-sound/icedtea-sound-1.0.1.ebuild
new file mode 100644
index 000000000000..8d57327bbb5f
--- /dev/null
+++ b/dev-java/icedtea-sound/icedtea-sound-1.0.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# Build written by Andrew John Hughes (gnu_andrew@member.fsf.org)
+
+EAPI="5"
+
+inherit eutils java-pkg-2 prefix
+
+DESCRIPTION="Plugins for javax.sound"
+HOMEPAGE="http://icedtea.classpath.org"
+SRC_URI="http://icedtea.classpath.org/download/source/${P}.tar.xz"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ppc64 x86"
+
+IUSE="+doc test"
+
+COMMON_DEP="
+ >=virtual/jdk-1.6.0
+ >=media-sound/pulseaudio-0.9.11:="
+RDEPEND="${COMMON_DEP}"
+DEPEND="${COMMON_DEP}"
+
+pkg_setup() {
+ JAVA_PKG_WANT_SOURCE="1.6"
+ JAVA_PKG_WANT_TARGET="1.6"
+
+ java-pkg-2_pkg_setup
+}
+
+src_configure() {
+ econf --with-jdk-home="${JAVA_HOME}" \
+ $(use_enable doc docs) \
+ --htmldir="${EROOT}usr/share/doc/${PF}/html"
+}
+
+src_compile() {
+ default
+}