summaryrefslogtreecommitdiff
path: root/dev-java/balloontip
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-java/balloontip
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-java/balloontip')
-rw-r--r--dev-java/balloontip/Manifest6
-rw-r--r--dev-java/balloontip/balloontip-1.2.1.ebuild38
-rw-r--r--dev-java/balloontip/files/balloontip-1.2.1-build.xml194
-rw-r--r--dev-java/balloontip/metadata.xml8
4 files changed, 246 insertions, 0 deletions
diff --git a/dev-java/balloontip/Manifest b/dev-java/balloontip/Manifest
new file mode 100644
index 000000000000..0bc295bbd426
--- /dev/null
+++ b/dev-java/balloontip/Manifest
@@ -0,0 +1,6 @@
+AUX balloontip-1.2.1-build.xml 8493 SHA256 e66b824bbe2e705fcc04b40db9d6194a2062b8a9cebc60d856196bf7bfc3681e SHA512 8fac922c637b09f54b72235ba50f78cfddedb6c75fc912a4575fa6064165b4723848b81ebf960254f82a0a56e07f3fcd43895d60b90237759fc10df10460e53f WHIRLPOOL ea6ac6585f3bcc9aa4dd0cc90af5f441bdc41c987cb43563cd25d220c40ee9571e1111ab4befe092fc268b7f656fc258d2ecdedf6242d33476f0b7aa10e63db9
+DIST balloontip_1.2.1.zip 822609 SHA256 d2905d5ec8ce7058a10ccd8881f0444e7703239e252bfc14f427084f64e8f208 SHA512 566e38767627b73324415b329d4f3e06e37572431bb34a022cbc81daf6057f9ab20da673702b2084a0026b70e7135aa8ae83f074ecea0c5a785e5006136ac91b WHIRLPOOL d896c8b9342b5087ee787d2caed0f2071948d23a5c434369042dfd20328957e906b363056b6fcb3e5aad59e1ba4bd5ad2df7830bfb14cc70881aa2f992c105a0
+EBUILD balloontip-1.2.1.ebuild 886 SHA256 40d35cef7f7233acda6d18418518f08e8d48c41e3f44150a28046849f973783d SHA512 47c2185039a48c005c455615fb6df33ea64c0106678191c710d1cd98e2879457d4d93114dcd4beb61ba59e3bc28d1fe05f02fd763e3a1e6a90b4e3519073252a WHIRLPOOL 26f871ba1e34d57efb37b75e86841c8897391c78965fb6e28750f80ba10294b1c25cba2a2cef87463189164d00dd894ae8dd68b45be3297fb3638e5a4de033a1
+MISC ChangeLog 2686 SHA256 f0ab799f2f33a29c19a5ce1bed1ffc3e4f1f514462734ab5c381d4858f2379c1 SHA512 4aa87bd075d593645bd1f5ecc72c902d063805faf7a4295d106a259772d9608ead8f716c567ae2560c9d18381bc4334214a3ca2f84fa630b89873cbc7d78b4b5 WHIRLPOOL ad0089fa81fb145c56621b6d5309dfea41b7935f9204ca06a41ef02c537a5c71bac7cc81a7ebddfa85fa23715fc5f558619e11674dfdb30b6d50c6d2ad65a2e4
+MISC ChangeLog-2015 778 SHA256 8379ed7c9f71b0acb2f633a6570ca7f9e5e5190cb10481b1593a208cd3c55b7d SHA512 32930d1f396d51d59098dc036e01adaa26219d07071d3347c3e2175fb8b2de53170f1a83238f56ce94c0a225545c17e08d95dd668a10b8dbe5b442e6adacc88f WHIRLPOOL 1272b154c07781188b10a9685dd2a7cd36fe6c4380210bef3790eb1577058ab4311a6c0644171c4cdb3e2a32a09550758750158951cc11bf46da6b61508db5cf
+MISC metadata.xml 232 SHA256 0c8d91b3d514ac42d0eaca567346ab909c0f947049c85c25a380ec2400f1b3fb SHA512 00beaf2c81112ff757c4395f4ea47e85f2d48e369e241f10ddf200090dd6513d52ae2b1aef6d28b7417f1cf34608a7258a167eb307d5670323a2190f3710f893 WHIRLPOOL 3a1a6d054edc9177d85ca868f9b0a6e84ee51bab4fbdbb9b1ead1a03874036bcc3f96e903fb751dc4d29fdb7d6b5f3d8dbe7b042fc697c887e23f41cc9c8c4ac
diff --git a/dev-java/balloontip/balloontip-1.2.1.ebuild b/dev-java/balloontip/balloontip-1.2.1.ebuild
new file mode 100644
index 000000000000..8f12b47cfdd6
--- /dev/null
+++ b/dev-java/balloontip/balloontip-1.2.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc examples source"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="A balloon tip component to spice up your Java Swing applications"
+HOMEPAGE="https://balloontip.java.net/"
+SRC_URI="https://java.net/projects/${PN}/downloads/download/${PN}_${PV}.zip"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND=">=virtual/jre-1.6"
+DEPEND=">=virtual/jdk-1.6"
+
+S="${WORKDIR}/${PN}_${PV}/src/${PN}"
+
+java_prepare() {
+ find . -name "*.jar" -delete || die
+
+ cp "${FILESDIR}"/${P}-build.xml build.xml || die
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar
+
+ dodoc "${WORKDIR}"/${PN}_${PV}/README.txt
+
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use examples && java-pkg_doexamples "${S}-examples"
+ use source && java-pkg_dosrc src/main/java/*
+
+}
diff --git a/dev-java/balloontip/files/balloontip-1.2.1-build.xml b/dev-java/balloontip/files/balloontip-1.2.1-build.xml
new file mode 100644
index 000000000000..01613ad720ec
--- /dev/null
+++ b/dev-java/balloontip/files/balloontip-1.2.1-build.xml
@@ -0,0 +1,194 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 7/13/13 1:34 PM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="balloontip-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="balloontip-1.2.1"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath"/>
+ <path id="build.test.classpath"/>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" depends="get-deps" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ <copy todir="${maven.build.outputDir}">
+ <fileset dir="${maven.build.resourceDir.0}"/>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases"/>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ linksource="false"
+ breakiterator="false">
+ <bottom>&lt;![CDATA[&lt;a href=&quot;http://balloontip.java.net/&quot;&gt;http://balloontip.java.net/&lt;/a&gt;]]&gt;</bottom>
+ </javadoc>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+ <target name="get-deps"
+ depends="test-offline"
+ description="Download all dependencies"
+ unless="maven.mode.offline">
+ <mkdir dir="${maven.repo.local}"/>
+ </target>
+
+</project>
diff --git a/dev-java/balloontip/metadata.xml b/dev-java/balloontip/metadata.xml
new file mode 100644
index 000000000000..2444066aa02b
--- /dev/null
+++ b/dev-java/balloontip/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+</maintainer>
+</pkgmetadata>