summaryrefslogtreecommitdiff
path: root/dev-haskell/cabal/cabal-2.0.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-04 12:06:33 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-04 12:06:33 +0000
commita833e3f4a431b8eea751b7420e127787f9c92117 (patch)
treeb941d23e9e3d5f070b01feb15ef927839af7456a /dev-haskell/cabal/cabal-2.0.0.2.ebuild
parent4cd2370bed609c118b6edfde5d3f116e5c35b897 (diff)
gentoo resync : 04.12.2017
Diffstat (limited to 'dev-haskell/cabal/cabal-2.0.0.2.ebuild')
-rw-r--r--dev-haskell/cabal/cabal-2.0.0.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-haskell/cabal/cabal-2.0.0.2.ebuild b/dev-haskell/cabal/cabal-2.0.0.2.ebuild
new file mode 100644
index 000000000000..6940bc3c4e4d
--- /dev/null
+++ b/dev-haskell/cabal/cabal-2.0.0.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.3.9999
+#hackport: flags: -parsec-struct-diff
+
+CABAL_FEATURES="lib profile test-suite"
+CABAL_FEATURES+=" nocabaldep" # in case installed Cabal is broken
+inherit haskell-cabal
+
+MY_PN="Cabal"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A framework for packaging Haskell software"
+HOMEPAGE="http://www.haskell.org/cabal/"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+#not keyworded yet: many packages are broken
+#KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RESTRICT=test # circular dependencies
+
+RDEPEND=">=dev-lang/ghc-7.8.1:="
+DEPEND="${RDEPEND}"
+
+CABAL_CORE_LIB_GHC_PV="PM:8.2.1"
+
+PATCHES=("${FILESDIR}"/${P}-no-bootstrap.patch)
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-parsec-struct-diff
+}