summaryrefslogtreecommitdiff
path: root/dev-dotnet/gio-sharp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-dotnet/gio-sharp
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-dotnet/gio-sharp')
-rw-r--r--dev-dotnet/gio-sharp/Manifest3
-rw-r--r--dev-dotnet/gio-sharp/gio-sharp-0.3-r1.ebuild42
-rw-r--r--dev-dotnet/gio-sharp/metadata.xml11
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-dotnet/gio-sharp/Manifest b/dev-dotnet/gio-sharp/Manifest
new file mode 100644
index 000000000000..c6c2c11d3fa4
--- /dev/null
+++ b/dev-dotnet/gio-sharp/Manifest
@@ -0,0 +1,3 @@
+DIST gio-sharp-0.3.tar.gz 89752 BLAKE2B 8c2ff7ec2fa1491d3fa4a3b8c8abe39dffe18f7f59a8866575cab298e84a5f5404467d02480e617d22214eb48bca0f70b7fb60b1a87aa91c36f970444edbcd8a SHA512 69a3e5db422403fa756a25818a7db5adcf6c1bef81b1f10ce5dc4bdb63ea1462c3a9ea4a4f987b0e30dc444499258c1aac279005d045c8709187bae7f095a66a
+EBUILD gio-sharp-0.3-r1.ebuild 877 BLAKE2B c79bda205e1290d8cfdfe0359ceb2459b617d465854e9243f9c29667652a6bb5c13661d673e07bc52923bbfa9d9716fcec4c749c1343e164d2cc71ee3db4bb89 SHA512 c24dca9e3206b7d10e1fd62211ebfc24b06e9bfa78e4a2ed94724534cfc02d34e17ce83e388e08f1c5e9ca2327e193ed932801aecf5bd412e6144cc2652355c2
+MISC metadata.xml 344 BLAKE2B 0c5d1368fd021a6a3f2b17fb3ed74599f35ce3537b7a387152b6fc79a3eb41543c10f502e1fd6a827910936b5241b7cba90adb319c848956f018fba67c15cf21 SHA512 38974d7a9152adb04c894a127919113983804802bb7a24f53528f8b2a542d9e15630b16bb55d344f4522d03566a03ef29997b8939ea4dd6f79b77b176a0a7c49
diff --git a/dev-dotnet/gio-sharp/gio-sharp-0.3-r1.ebuild b/dev-dotnet/gio-sharp/gio-sharp-0.3-r1.ebuild
new file mode 100644
index 000000000000..85ddc3568b0d
--- /dev/null
+++ b/dev-dotnet/gio-sharp/gio-sharp-0.3-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit autotools mono-env
+
+DESCRIPTION="GIO API C# binding"
+HOMEPAGE="https://github.com/mono/gio-sharp"
+SRC_URI="https://github.com/mono/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="|| ( >=dev-dotnet/gtk-sharp-2.12.21 >=dev-dotnet/glib-sharp-2.12 )
+ || ( >=dev-dotnet/gtk-sharp-2.12.21 >=dev-dotnet/gtk-sharp-gapi-2.12 )
+ >=dev-libs/glib-2.22:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ DOCS="AUTHORS NEWS README"
+ mono-env_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ mv *-${PN}-* "${S}"
+}
+
+src_prepare() {
+ sed -i -e 's/gmcs/mcs/' configure.ac.in || die
+ sed -i -e '/autoreconf/d' autogen-generic.sh || die
+ NOCONFIGURE=1 ./autogen-2.22.sh || die
+
+ eautoreconf
+}
+
+src_compile() {
+ emake -j1
+}
diff --git a/dev-dotnet/gio-sharp/metadata.xml b/dev-dotnet/gio-sharp/metadata.xml
new file mode 100644
index 000000000000..89d6dbfb280e
--- /dev/null
+++ b/dev-dotnet/gio-sharp/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>dotnet@gentoo.org</email>
+ <name>Gentoo Dotnet Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mono/gio-sharp</remote-id>
+ </upstream>
+</pkgmetadata>