summaryrefslogtreecommitdiff
path: root/dev-cpp/robin-hood-hashing
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /dev-cpp/robin-hood-hashing
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'dev-cpp/robin-hood-hashing')
-rw-r--r--dev-cpp/robin-hood-hashing/Manifest3
-rw-r--r--dev-cpp/robin-hood-hashing/metadata.xml15
-rw-r--r--dev-cpp/robin-hood-hashing/robin-hood-hashing-3.11.2.ebuild18
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-cpp/robin-hood-hashing/Manifest b/dev-cpp/robin-hood-hashing/Manifest
new file mode 100644
index 000000000000..3af25b6a84f3
--- /dev/null
+++ b/dev-cpp/robin-hood-hashing/Manifest
@@ -0,0 +1,3 @@
+DIST robin-hood-hashing-3.11.2.tar.gz 170488 BLAKE2B 5fb688f5e21f989456e139b64447393816593ad2a1c3537d067d8ea1717aceaa879e27616657354f62e1466ca491f9d302448a73cddb53c7156a623eb375016b SHA512 5d55f054e29ae34d410eb0103f9f0aa1faf47e313b9f089c73b9c26fd9bedf132f6bb13b4bcd2664309c32fe7e859e346d0a6e7ab7f46b294f9b8db207577795
+EBUILD robin-hood-hashing-3.11.2.ebuild 481 BLAKE2B 4b9ec0837cfd3bb3584b61577489fffb4bc66052def4b6f79759a5301d5aa310da2b4f288179257a6bd394622e41e5c8076f5bc9286bd30d99f62dc448baee9a SHA512 b6db825452c417502eb3d093a910beb2b9a3eff6e079a6ad6b04aefbe66244134db549dd45284a7a4217573ccfe44ba27389e270c7a53af7804fe6c893c5f388
+MISC metadata.xml 431 BLAKE2B 301a6f1026a18fd6d6322f95833f515247111fb9bb88d915724c263e167ea93bbc7f72a734c1aa4fffb5e2068a43f42a104446e7dddaf56334c73eb29541481a SHA512 80aac4cd60e6768675f5cf8619b99d7e4d95b3c691dd4cd7400040610abfdc5f9182e166f5b1c301a14380a3216fca87613dd7e4098fe2e1e2330e49f0660654
diff --git a/dev-cpp/robin-hood-hashing/metadata.xml b/dev-cpp/robin-hood-hashing/metadata.xml
new file mode 100644
index 000000000000..c64c3ac674d9
--- /dev/null
+++ b/dev-cpp/robin-hood-hashing/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>x11@gentoo.org</email>
+ <name>X11</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>sarnex@gentoo.org</email>
+ <name>Nick Sarnie</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">martinus/robin-hood-hashing</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-cpp/robin-hood-hashing/robin-hood-hashing-3.11.2.ebuild b/dev-cpp/robin-hood-hashing/robin-hood-hashing-3.11.2.ebuild
new file mode 100644
index 000000000000..13577d90c006
--- /dev/null
+++ b/dev-cpp/robin-hood-hashing/robin-hood-hashing-3.11.2.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+SRC_URI="https://github.com/martinus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+DESCRIPTION="Fast & memory efficient hashtable based on robin hood hashing for C++11/14/17/20"
+HOMEPAGE="https://github.com/martinus/robin-hood-hashing"
+
+LICENSE="MIT"
+SLOT="0"
+
+src_install() {
+ insinto /usr/include
+ doins src/include/robin_hood.h
+}