summaryrefslogtreecommitdiff
path: root/app-vim/csound-syntax/csound-syntax-0.8.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /app-vim/csound-syntax/csound-syntax-0.8.1.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'app-vim/csound-syntax/csound-syntax-0.8.1.ebuild')
-rw-r--r--app-vim/csound-syntax/csound-syntax-0.8.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-vim/csound-syntax/csound-syntax-0.8.1.ebuild b/app-vim/csound-syntax/csound-syntax-0.8.1.ebuild
new file mode 100644
index 000000000000..a2e3cf0246cc
--- /dev/null
+++ b/app-vim/csound-syntax/csound-syntax-0.8.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+MY_P="csound-vim-${PV}"
+
+DESCRIPTION="vim plugin: set of tools for editing Csound files with vim"
+HOMEPAGE="https://github.com/luisjure/csound"
+SRC_URI="https://github.com/luisjure/csound-vim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+PATCHES=( "${FILESDIR}/${PN}-doc.patch" )
+
+src_prepare() {
+ rm -v LICENSE README.md || die
+ default
+}