summaryrefslogtreecommitdiff
path: root/app-text/fbreader/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/fbreader/files
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/fbreader/files')
-rw-r--r--app-text/fbreader/files/fbreader-0.99.4-gcc6.patch11
-rw-r--r--app-text/fbreader/files/fbreader-0.99.4-ld-bfd.patch10
-rw-r--r--app-text/fbreader/files/fbreader-0.99.4-mimetypes.patch6
-rw-r--r--app-text/fbreader/files/fbreader-0.99.4-qreal-cast.patch13
-rw-r--r--app-text/fbreader/files/fbreader-0.99.4.patch8
5 files changed, 48 insertions, 0 deletions
diff --git a/app-text/fbreader/files/fbreader-0.99.4-gcc6.patch b/app-text/fbreader/files/fbreader-0.99.4-gcc6.patch
new file mode 100644
index 000000000000..c6f87a292697
--- /dev/null
+++ b/app-text/fbreader/files/fbreader-0.99.4-gcc6.patch
@@ -0,0 +1,11 @@
+--- fbreader/src/formats/doc/OleStorage.cpp 2012-11-30 13:41:25.000000000 +0100
++++ fbreader/src/formats/doc/OleStorage.cpp-new 2016-08-31 17:23:18.232536401 +0200
+@@ -59,7 +59,7 @@
+ clear();
+ return false;
+ }
+- static const char OLE_SIGN[] = {0xD0, 0xCF, 0x11, 0xE0, 0xA1, 0xB1, 0x1A, 0xE1, 0};
++ static const char OLE_SIGN[] = {(char)0xD0, (char)0xCF, (char)0x11, (char)0xE0, (char)0xA1, (char)0xB1, (char)0x1A, (char)0xE1, 0};
+ if (std::strncmp(oleBuf, OLE_SIGN, 8) != 0) {
+ clear();
+ return false;
diff --git a/app-text/fbreader/files/fbreader-0.99.4-ld-bfd.patch b/app-text/fbreader/files/fbreader-0.99.4-ld-bfd.patch
new file mode 100644
index 000000000000..ab872edf17cd
--- /dev/null
+++ b/app-text/fbreader/files/fbreader-0.99.4-ld-bfd.patch
@@ -0,0 +1,10 @@
+diff -r -U2 fbreader-0.99.4.orig/fbreader/Makefile fbreader-0.99.4/fbreader/Makefile
+--- fbreader-0.99.4.orig/fbreader/Makefile 2012-11-30 19:41:25.000000000 +0700
++++ fbreader-0.99.4/fbreader/Makefile 2016-08-31 19:06:35.011708982 +0700
+@@ -23,5 +23,5 @@
+ done;
+ @echo -n 'Linking $(TARGET) ...'
+- @$(LD) $(LDFLAGS) -o $(TARGET) `find src -name *.o` $(TEXT_LIBS) $(CORE_LIBS) $(ZLUI_LIB) -lsqlite3
++ @$(LD) -fuse-ld=bfd $(LDFLAGS) -o $(TARGET) `find src -name *.o` $(TEXT_LIBS) $(CORE_LIBS) $(ZLUI_LIB) -lsqlite3
+ @echo ' OK'
+
diff --git a/app-text/fbreader/files/fbreader-0.99.4-mimetypes.patch b/app-text/fbreader/files/fbreader-0.99.4-mimetypes.patch
new file mode 100644
index 000000000000..0e4a2935d442
--- /dev/null
+++ b/app-text/fbreader/files/fbreader-0.99.4-mimetypes.patch
@@ -0,0 +1,6 @@
+diff -r -U1 fbreader-0.99.4.orig/fbreader/desktop/desktop fbreader-0.99.4/fbreader/desktop/desktop
+--- fbreader-0.99.4.orig/fbreader/desktop/desktop 2012-11-30 19:41:25.000000000 +0700
++++ fbreader-0.99.4/fbreader/desktop/desktop 2014-07-10 20:56:33.527638562 +0700
+@@ -23 +23,2 @@
+ Categories=Office;Viewer;Literature;
++MimeType=application/epub+zip;application/rtf;application/x-fictionbook+xml;application/x-zip-compressed-fb2;application/x-mobipocket-ebook;application/xhtml+xml;text/html;text/plain;
diff --git a/app-text/fbreader/files/fbreader-0.99.4-qreal-cast.patch b/app-text/fbreader/files/fbreader-0.99.4-qreal-cast.patch
new file mode 100644
index 000000000000..ffd21b2924f7
--- /dev/null
+++ b/app-text/fbreader/files/fbreader-0.99.4-qreal-cast.patch
@@ -0,0 +1,13 @@
+diff -r -U1 fbreader-0.99.4.orig/zlibrary/ui/src/qt4/tree/QtWaitingSpinner.cpp fbreader-0.99.4/zlibrary/ui/src/qt4/tree/QtWaitingSpinner.cpp
+--- fbreader-0.99.4.orig/zlibrary/ui/src/qt4/tree/QtWaitingSpinner.cpp 2012-11-30 19:41:25.000000000 +0700
++++ fbreader-0.99.4/zlibrary/ui/src/qt4/tree/QtWaitingSpinner.cpp 2014-07-10 19:18:17.002886537 +0700
+@@ -88,3 +88,3 @@
+ void QtWaitingSpinner::setRoundness(qreal roundness) {
+- myRoundness = std::max(0.0, std::min(100.0, roundness));
++ myRoundness = std::max(static_cast<qreal>(0.0), std::min(static_cast<qreal>(100.0), roundness));
+ }
+@@ -150,3 +150,3 @@
+ qreal resultAlpha = color.alphaF() - gradation * distance;
+- resultAlpha = std::min(1.0, std::max(0.0, resultAlpha)); //if alpha is out of bound, force it to bounds
++ resultAlpha = std::min(static_cast<qreal>(1.0), std::max(static_cast<qreal>(0.0), resultAlpha)); //if alpha is out of bound, force it to bounds
+ color.setAlphaF(resultAlpha);
diff --git a/app-text/fbreader/files/fbreader-0.99.4.patch b/app-text/fbreader/files/fbreader-0.99.4.patch
new file mode 100644
index 000000000000..deb90228301d
--- /dev/null
+++ b/app-text/fbreader/files/fbreader-0.99.4.patch
@@ -0,0 +1,8 @@
+diff -r -U2 fbreader-0.99.4.orig/zlibrary/ui/src/qt4/filesystem/ZLQtFSManager.cpp fbreader-0.99.4/zlibrary/ui/src/qt4/filesystem/ZLQtFSManager.cpp
+--- fbreader-0.99.4.orig/zlibrary/ui/src/qt4/filesystem/ZLQtFSManager.cpp 2012-11-30 19:41:25.000000000 +0700
++++ fbreader-0.99.4/zlibrary/ui/src/qt4/filesystem/ZLQtFSManager.cpp 2013-02-21 13:30:31.000000000 +0700
+@@ -49,3 +49,4 @@
+ path = replacement + path.substr(1);
+ }
++ ZLUnixFSManager::normalizeRealPath(path);
+ }