summaryrefslogtreecommitdiff
path: root/app-shells/rssh/rssh-2.3.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-shells/rssh/rssh-2.3.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-shells/rssh/rssh-2.3.4.ebuild')
-rw-r--r--app-shells/rssh/rssh-2.3.4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-shells/rssh/rssh-2.3.4.ebuild b/app-shells/rssh/rssh-2.3.4.ebuild
new file mode 100644
index 000000000000..c7f65ae63eff
--- /dev/null
+++ b/app-shells/rssh/rssh-2.3.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit eutils multilib
+
+DESCRIPTION="Restricted shell for SSHd"
+HOMEPAGE="http://rssh.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rssh/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc x86"
+IUSE="static"
+
+RDEPEND="virtual/ssh"
+
+src_prepare() {
+ epatch_user
+
+ sed -i 's:chmod u+s $(:chmod u+s $(DESTDIR)$(:' Makefile.in || die
+ # respect CFLAGS, bug #450458
+ sed -i -e '/$(CC) -c/s/$(CPPFLAGS)/$(CFLAGS)/' Makefile.in || die
+}
+
+src_configure() {
+ econf \
+ --libexecdir="/usr/$(get_libdir)/misc" \
+ --with-scp=/usr/bin/scp \
+ --with-sftp-server="/usr/$(get_libdir)/misc/sftp-server" \
+ $(use_enable static)
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc AUTHORS ChangeLog CHROOT INSTALL README TODO
+}