summaryrefslogtreecommitdiff
path: root/app-shells/rrs/rrs-1.70-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-shells/rrs/rrs-1.70-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-shells/rrs/rrs-1.70-r1.ebuild')
-rw-r--r--app-shells/rrs/rrs-1.70-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-shells/rrs/rrs-1.70-r1.ebuild b/app-shells/rrs/rrs-1.70-r1.ebuild
new file mode 100644
index 000000000000..1bc50a484efe
--- /dev/null
+++ b/app-shells/rrs/rrs-1.70-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Reverse Remote Shell"
+HOMEPAGE="http://freecode.com/projects/rrs"
+SRC_URI="http://www.cycom.se/uploads/36/19/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="ssl"
+
+DEPEND="ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/"${P}"-asneeded.patch
+ sed -i -e "s/-s //g" Makefile || die
+}
+
+src_compile() {
+ local target=""
+ use ssl || target="-nossl"
+
+ emake generic${target} CFLAGS="${CFLAGS}" LDEXTRA="${LDFLAGS}" CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin rrs
+ dodoc CHANGES README
+ doman rrs.1
+}