summaryrefslogtreecommitdiff
path: root/app-shells/powerline
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /app-shells/powerline
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'app-shells/powerline')
-rw-r--r--app-shells/powerline/Manifest4
-rw-r--r--app-shells/powerline/metadata.xml17
-rw-r--r--app-shells/powerline/powerline-2.7.ebuild26
-rw-r--r--app-shells/powerline/powerline-9999.ebuild26
4 files changed, 73 insertions, 0 deletions
diff --git a/app-shells/powerline/Manifest b/app-shells/powerline/Manifest
new file mode 100644
index 000000000000..a878cf5dab7c
--- /dev/null
+++ b/app-shells/powerline/Manifest
@@ -0,0 +1,4 @@
+DIST powerline-status-2.7.tar.gz 233726 BLAKE2B fc7b7d6aa5d8e050af07aeee0aa0b7f6f01b7483ea910b87a7027cd55f726d42e41a008feb07429b21ebbd890b12eb56581b8e47fc30a58de6b902bf14d999cb SHA512 053ab74d250b7d835a5f8ec9cb7da4e890f0f50d31be9bab4b393a85e087a6fc010e58d6b3fa530cf39c10671345d032ca1fa9c0f7887a89fea8a4e69b7f1517
+EBUILD powerline-2.7.ebuild 682 BLAKE2B ff81667b6a8f94cf95b579f5c456a85db05dcb03f7d3799564c43c191cde961c3d9473891cea7444f327ac61b02dc5df7d638d8fb6f2bce761914a51ffca3add SHA512 b42ad0cf024ed32d253a88f29b36b12dfa0e5155caecff931485ab6d23cdb2b192b0de812126142a66f7dcbbbaf12254674b2ea43b476e8898be863af3cf4d78
+EBUILD powerline-9999.ebuild 682 BLAKE2B ff81667b6a8f94cf95b579f5c456a85db05dcb03f7d3799564c43c191cde961c3d9473891cea7444f327ac61b02dc5df7d638d8fb6f2bce761914a51ffca3add SHA512 b42ad0cf024ed32d253a88f29b36b12dfa0e5155caecff931485ab6d23cdb2b192b0de812126142a66f7dcbbbaf12254674b2ea43b476e8898be863af3cf4d78
+MISC metadata.xml 620 BLAKE2B 3c392d83a62425429cc89d0ac8dff925d98a392aa1d84bc0c7e84dd2871ded1566b0b66afe34b201672a51b23650cc2e18320c5e4e98b4b5042099340cae4b56 SHA512 10f3ce6affeed34d2b48a922a64eb2b1b1a628ed9d5e9a78f92eec3b264d633ce75b09e83e2cc3deae074ac27cd9f1bd2adcdb5f77e8deacdcd876d849977f60
diff --git a/app-shells/powerline/metadata.xml b/app-shells/powerline/metadata.xml
new file mode 100644
index 000000000000..aa2c5f9bee3f
--- /dev/null
+++ b/app-shells/powerline/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ Powerline is a statusline plugin for vim, and provides statuslines and
+ prompts for several other applications, including zsh, bash, fish,
+ tmux, IPython, Awesome, i3 and Qtile.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">powerline-status</remote-id>
+ <remote-id type="github">powerline/powerline</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-shells/powerline/powerline-2.7.ebuild b/app-shells/powerline/powerline-2.7.ebuild
new file mode 100644
index 000000000000..79ff69b517e6
--- /dev/null
+++ b/app-shells/powerline/powerline-2.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="The ultimate statusline/prompt utility."
+HOMEPAGE="https://github.com/powerline/powerline"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/powerline/powerline"
+ EGIT_BRANCH="develop"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}-status/${PN}-status-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+S="${WORKDIR}/${PN}-status-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
diff --git a/app-shells/powerline/powerline-9999.ebuild b/app-shells/powerline/powerline-9999.ebuild
new file mode 100644
index 000000000000..79ff69b517e6
--- /dev/null
+++ b/app-shells/powerline/powerline-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="The ultimate statusline/prompt utility."
+HOMEPAGE="https://github.com/powerline/powerline"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/powerline/powerline"
+ EGIT_BRANCH="develop"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}-status/${PN}-status-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+S="${WORKDIR}/${PN}-status-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""