summaryrefslogtreecommitdiff
path: root/app-misc/mosquitto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-19 08:36:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-19 08:36:10 +0100
commit19a10140592052698d68be11db5a59bc88fcf528 (patch)
tree4af8926304f638633a3b9d0947126950c8cb01a0 /app-misc/mosquitto
parentd1989de9d66ba4285e46f80cd571d5a82beae871 (diff)
gentoo auto-resync : 19:08:2022 - 08:36:10
Diffstat (limited to 'app-misc/mosquitto')
-rw-r--r--app-misc/mosquitto/Manifest2
-rw-r--r--app-misc/mosquitto/mosquitto-2.0.15.ebuild125
2 files changed, 127 insertions, 0 deletions
diff --git a/app-misc/mosquitto/Manifest b/app-misc/mosquitto/Manifest
index b05d10df4de1..209865d6713a 100644
--- a/app-misc/mosquitto/Manifest
+++ b/app-misc/mosquitto/Manifest
@@ -1,5 +1,7 @@
AUX mosquitto 559 BLAKE2B 16a34850c13d9fd6007b5fbd26b4db9e31caa0ee91b8eee8dbca605c273756bf6c92458d5093eee56f603cce7f10956ee084403e188d49693a759538976f411f SHA512 0bb0e648484269c2a5396118340177af10fae9ccbe4973371f7c8f5e31c96ff97c5146680415c450bad63397baa5c076e7c994f897fd3af2fcce0d1e0965ee22
AUX mosquitto.service 261 BLAKE2B 6ea8059914acf8730f2e7d04bfd5f79c59a335b65ddecb4773bb4418260c6ed6d0120eaa2e3f7ba4842fc7014e5b51d1ba376cf1db2009b7a55a53a4e6747221 SHA512 3552618733fc106705375c5a1126db72e356694705312072f27f18e21c142cd75ae3ff1f17854ce54cdee092ff9e01fd75c1a8a12d68f75ead8a3697c69623e9
DIST mosquitto-2.0.14.tar.gz 787414 BLAKE2B 926e39756a0293404c8591e489e64e47cd95640d7884f2cfb687a0d548b709d8aff6d671a4941aae8b3506315d28567520c183b762639822d2d78afe323d111e SHA512 a9e4f41b9af679b30318570e86a465546024651373df10e3b132f4593b89d22d0dbac01bb7371a57132ba030a2e73971c612acb5c9ac12f5ccd06aa38d9444c2
+DIST mosquitto-2.0.15.tar.gz 792632 BLAKE2B a6e986998473c16efd4c5fc5fd743782e085b3e7e30bcdcb867f0ae87f85e608f5d50d0dcc5bbbcc2f25eb6a618ab2f287fdcba47660fa593fe1636d08eb183e SHA512 8a0c58222ea0b9304e7f096f6d13965478072baf1d1c9bc931b32a33f5ea8196c2dd54bde8d83fec7ed9cd413cb5fb115ce0a6701ca20664df52fdd7ca63ddaf
EBUILD mosquitto-2.0.14.ebuild 3023 BLAKE2B 7a4cf9ccc2408317a98a987d0c3a6c2e09c54e27e650691b7be52d804f84a91e572a8586d73c7e6c9c6cc702720514a397e74ac55160522e96ba605246e89288 SHA512 3bd54b5f2bf134a56be47a05dde1e1bf8b826cb8e20b107fa6095b2ed600614b3497c14543c0bf07815e9c5d83242be4f222e642706804ba2ff9c880e5dd46db
+EBUILD mosquitto-2.0.15.ebuild 2950 BLAKE2B b225214ec9e4325c79dff397f0cbe2ce3541258ec2e4a86e09d5177af3eb1e0b5601eb435df7340b989cddcca8f10c640c908bcaf7672a9d8fee29012d428c22 SHA512 c43b165497565e16d0042669742158f5fa2d3ffc61204ec32b2286b279c88d7c2fceaa260ef922aad736662e700513c0c5ba2303201963112083afcff32e7c80
MISC metadata.xml 612 BLAKE2B 414070cdd858c5fd76b266459ff7b2a66992e8b11e672212f78e366863cd221aa83516a546c69668217a06b087b7b81853fcdff332368355cd1ff8c1292f0c4e SHA512 64242d12473aad0f0d80865da2499679849f6b55f751d27c3cf38e0a5555a305a2cc59f8dfbe4b9d50f0a6b6bc85062b989511c7118045b2c9c3e1e0d1022747
diff --git a/app-misc/mosquitto/mosquitto-2.0.15.ebuild b/app-misc/mosquitto/mosquitto-2.0.15.ebuild
new file mode 100644
index 000000000000..a584158956db
--- /dev/null
+++ b/app-misc/mosquitto/mosquitto-2.0.15.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit python-any-r1 systemd toolchain-funcs
+
+DESCRIPTION="An Open Source MQTT v3 Broker"
+HOMEPAGE="https://mosquitto.org/ https://github.com/eclipse/mosquitto"
+SRC_URI="https://mosquitto.org/files/source/${P}.tar.gz"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="bridge examples +persistence +srv ssl tcpd test websockets"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="test? ( bridge )"
+
+RDEPEND="
+ acct-user/mosquitto
+ acct-group/mosquitto
+ dev-libs/cJSON:=
+ srv? ( net-dns/c-ares:= )
+ ssl? (
+ dev-libs/openssl:0=
+ )
+ tcpd? ( sys-apps/tcp-wrappers )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-util/cunit )
+ websockets? ( net-libs/libwebsockets[lejp] )
+"
+BDEPEND="
+ test? ( ${PYTHON_DEPS} )
+"
+
+pkg_setup() {
+ use test && python_setup
+}
+
+_emake() {
+ local LIBDIR=$(get_libdir)
+ emake \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ CLIENT_LDFLAGS="${LDFLAGS}" \
+ LIB_SUFFIX="${LIBDIR:3}" \
+ WITH_BRIDGE="$(usex bridge)" \
+ WITH_PERSISTENCE="$(usex persistence)" \
+ WITH_SRV="$(usex srv)" \
+ WITH_TLS="$(usex ssl)" \
+ WITH_WEBSOCKETS="$(usex websockets)" \
+ WITH_WRAP="$(usex tcpd)" \
+ "$@"
+}
+
+src_prepare() {
+ default
+ if use persistence; then
+ sed -i -e "/^#autosave_interval/s|^#||" \
+ -e "s|^#persistence false$|persistence true|" \
+ -e "/^#persistence_file/s|^#||" \
+ -e "s|#persistence_location|persistence_location /var/lib/mosquitto/|" \
+ mosquitto.conf || die
+ fi
+
+ # Remove failing tests
+ sed -i \
+ -e '/06-bridge-reconnect-local-out.py/d' \
+ test/broker/Makefile || die
+ sed -i \
+ -e '/02-subscribe-qos1-async2.test/d' \
+ test/lib/Makefile || die
+
+ # Extend test timeout to prevent spurious failures
+ sed -i -e 's/SUB_TIMEOUT=1/SUB_TIMEOUT=3/' \
+ test/client/test.sh || die
+
+ use test && python_fix_shebang test
+}
+
+src_compile() {
+ _emake
+}
+
+src_test() {
+ _emake test
+}
+
+src_install() {
+ _emake DESTDIR="${D}" prefix=/usr install
+ keepdir /var/lib/mosquitto
+ fowners mosquitto:mosquitto /var/lib/mosquitto
+ dodoc README.md CONTRIBUTING.md ChangeLog.txt
+ doinitd "${FILESDIR}"/mosquitto
+ insinto /etc/mosquitto
+ doins mosquitto.conf
+ insinto /usr/share/mosquitto
+ doins misc/letsencrypt/mosquitto-copy.sh
+ systemd_dounit "${FILESDIR}/mosquitto.service"
+
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+}
+
+pkg_postinst() {
+ for v in ${REPLACING_VERSIONS}; do
+ if [[ $(ver_cut 1 "$v") -lt 2 ]]; then
+ elog
+ elog "Please read the migration guide at:"
+ elog "https://mosquitto.org/documentation/migrating-to-2-0/"
+ elog
+ elog "If you use Lets Encrypt TLS certificates, take note of"
+ elog "the changes required to run the daemon as the unprivileged"
+ elog "mosquitto user. The mosquitto-copy.sh script has been"
+ elog "installed to /usr/share/mosquitto/ for your convenience."
+ elog
+ fi
+ done
+}