summaryrefslogtreecommitdiff
path: root/app-leechcraft/lc-monocle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-leechcraft/lc-monocle
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-leechcraft/lc-monocle')
-rw-r--r--app-leechcraft/lc-monocle/Manifest2
-rw-r--r--app-leechcraft/lc-monocle/lc-monocle-9999.ebuild46
-rw-r--r--app-leechcraft/lc-monocle/metadata.xml16
3 files changed, 64 insertions, 0 deletions
diff --git a/app-leechcraft/lc-monocle/Manifest b/app-leechcraft/lc-monocle/Manifest
new file mode 100644
index 000000000000..17439871c9d7
--- /dev/null
+++ b/app-leechcraft/lc-monocle/Manifest
@@ -0,0 +1,2 @@
+EBUILD lc-monocle-9999.ebuild 1013 BLAKE2B c7b16c6d9b044342c6f60e712642bfb8f072e14809c8689e9708e59cc0825a9c4bf4f6603a0ff94e06e16841d5c55295982c75ac35e94bc55f27f04a53c6ca7f SHA512 18e1c3aba49d625e8cf397270aee623653345ed2192d01f28ee004b026a541a5b637926f0ec81d22e075ded16800253ef0fd0ab251b60e79b828c2362e1d121f
+MISC metadata.xml 501 BLAKE2B 011d2a76ddb262226145c480a00834e6818887722f0d2125275738e0203e693b56eedb6ae04622c6ea7590057b091a34747ca25f5598ef303bdfe06fb4f99363 SHA512 7cc94be02505c74347bc6a08624b666269928e3277e808aeae0ca6931afe715ae55d80dad48862b0a4ca52c49902f452594b3fa7ac0252ad45fd14575e9a5869
diff --git a/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild b/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild
new file mode 100644
index 000000000000..fcd13b3dd384
--- /dev/null
+++ b/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit leechcraft
+
+DESCRIPTION="Monocle, the modular document viewer for LeechCraft"
+
+SLOT="0"
+KEYWORDS=""
+IUSE="debug +djvu doc +fb2 +mobi +pdf +postscript"
+
+REQUIRED_USE="postscript? ( pdf )"
+
+CDEPEND="~app-leechcraft/lc-core-${PV}
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtxml:5
+ pdf? ( app-text/poppler[qt5] )
+ djvu? ( app-text/djvu )"
+
+RDEPEND="${CDEPEND}
+ postscript? ( app-text/ghostscript-gpl )"
+
+DEPEND="${CDEPEND}
+ doc? ( app-doc/doxygen[dot] )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_MONOCLE_SEEN=$(usex djvu)
+ -DWITH_DOCS=$(usex doc)
+ -DENABLE_MONOCLE_FXB=$(usex fb2)
+ -DENABLE_MONOCLE_DIK=$(usex mobi)
+ -DENABLE_MONOCLE_PDF=$(usex pdf)
+ -DENABLE_MONOCLE_POSTRUS=$(usex postscript)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dodoc -r "${CMAKE_BUILD_DIR}"/out/html/*
+}
diff --git a/app-leechcraft/lc-monocle/metadata.xml b/app-leechcraft/lc-monocle/metadata.xml
new file mode 100644
index 000000000000..421dc6dc1773
--- /dev/null
+++ b/app-leechcraft/lc-monocle/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>0xd34df00d@gmail.com</email>
+ <name>Georg Rudoy</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="fb2">Enable support for FictionBook format</flag>
+ <flag name="mobi">Enable support for MOBI format</flag>
+ </use>
+</pkgmetadata>