summaryrefslogtreecommitdiff
path: root/app-emacs/yasnippet-snippets
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /app-emacs/yasnippet-snippets
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'app-emacs/yasnippet-snippets')
-rw-r--r--app-emacs/yasnippet-snippets/Manifest2
-rw-r--r--app-emacs/yasnippet-snippets/yasnippet-snippets-1.0-r1.ebuild (renamed from app-emacs/yasnippet-snippets/yasnippet-snippets-1.0.ebuild)8
2 files changed, 7 insertions, 3 deletions
diff --git a/app-emacs/yasnippet-snippets/Manifest b/app-emacs/yasnippet-snippets/Manifest
index 2a9b44d59f21..e97c0233a0a1 100644
--- a/app-emacs/yasnippet-snippets/Manifest
+++ b/app-emacs/yasnippet-snippets/Manifest
@@ -2,5 +2,5 @@ AUX 50yasnippet-snippets-gentoo.el 161 BLAKE2B af28f32bcf248a9557c25e4afd50110b6
DIST yasnippet-snippets-0.3.tar.gz 97229 BLAKE2B 26fe83c35be1b20b6a1e414144149cf1feaf4463833634bbd0a3db6f56b1da46d8e379c3dd19217cfd36f12cb9dc796eac4efef5c2ba472ce79f8c8b8d816969 SHA512 4aaac9d7c880642a1e802abb98bd6d6c94557fe0e609db5ce5b4ce2af921235d3e6bb2488c052adbe2940d41e85297520081ae0847b52642bc97610e6614727f
DIST yasnippet-snippets-1.0.tar.gz 178027 BLAKE2B 0b44c94c3ad3f2a1208aefba110945aeae74e7278c93078c59677985efc89767b670c99b4b8303b56ea0b748375762ada1e45653e02922b248273af5818514d4 SHA512 2df010f24e51d0156bcb3d488cd6a63a47d2d92e4c5f3cd081e377dc91426d630bde41db6f79d1b5ac1e932e4d0ab11f9be945e94fb35d50b1789adab19bd15b
EBUILD yasnippet-snippets-0.3.ebuild 614 BLAKE2B 73559131e05601b6a1f80ee513e8a2eef5f718d9b037476adfe2dfdb9d15162ee0dc6e2b249851aa1e3aef2ebf0b9363eab6f9e2996adf1d5c19496d75b3012c SHA512 d9d3d0044e4a527ce6b8b0e93f9ec4e63ac0a331d2834c9d283d9cd5f00c0627ece69b5ae17e346401cd345ec32a2daf97f7c86e1833980de2689b85bf0bb89b
-EBUILD yasnippet-snippets-1.0.ebuild 611 BLAKE2B 78a8ae161f1b000d3a7d17c160767f74a7e9a0b758f419c3aef625347f0a497017585fcb35ce153d7cebc8008cd1f1a2d43693df222d98b61341c7c4c98f40da SHA512 b7ed9b5b6435ce5a70ef8d470db964be6b4f88001569bda80ec3ebf203d2160f74e15bee0a4670f7c45a7f8e310c67cb6f251e9cfb59e047ebcc8752328f054a
+EBUILD yasnippet-snippets-1.0-r1.ebuild 747 BLAKE2B cb4f16c89083b1cd22fc38c6988808a6dd6a7b77fcdf45216503dd13e39ce0e4f162ac357ad7d9aec9c7085969c0416d39f06bd14fa3281f8d18d5829e462770 SHA512 36d4c6c34ec69e8fcbc003abdbff220f24662f403d38c101d386c3a0f830b46a7afedac12ed830fce911a344020e73ac0a2c2fb1812580ff5fd1f9d1c65455da
MISC metadata.xml 377 BLAKE2B 78f369ac63a6ba16eabfbc21367b0e29221a94a8460b877e58b23e4c4176e3d4393ac7cb657057fe239298fc9836365b8a5d6ec789251ed552e684590b40e6e4 SHA512 72e8f247f2bb604ea52229c1aa68abf0fdd6649c87ffaad7f2893131f522cc3d7283251d8e365def16ac5eea831c98472a0ebe591cb6188132e0d7696b559b55
diff --git a/app-emacs/yasnippet-snippets/yasnippet-snippets-1.0.ebuild b/app-emacs/yasnippet-snippets/yasnippet-snippets-1.0-r1.ebuild
index 3b0d29b244e7..3b465cd3954b 100644
--- a/app-emacs/yasnippet-snippets/yasnippet-snippets-1.0.ebuild
+++ b/app-emacs/yasnippet-snippets/yasnippet-snippets-1.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -14,10 +14,14 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="app-emacs/yasnippet"
+BDEPEND="${RDEPEND}"
SITEFILE="50${PN}-gentoo.el"
-src_compile() { :; }
+src_compile() {
+ ${EMACS} ${EMACSFLAGS} --eval "(require 'yasnippet)" \
+ --eval "(yas-compile-directory \"${S}/snippets\")" || die
+}
src_install() {
elisp-site-file-install "${FILESDIR}/${SITEFILE}"