summaryrefslogtreecommitdiff
path: root/app-editors/qemacs/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-editors/qemacs/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-editors/qemacs/files')
-rw-r--r--app-editors/qemacs/files/qemacs-0.4.1_pre20150916-Makefile.patch38
-rw-r--r--app-editors/qemacs/files/qemacs-0.4.1_pre20150916-nostrip.patch38
-rw-r--r--app-editors/qemacs/files/qemacs-0.4.1_pre20170225-Makefile.patch42
-rw-r--r--app-editors/qemacs/files/qemacs-0.4.1_pre20170225-manpage.patch11
-rw-r--r--app-editors/qemacs/files/qemacs-0.4.1_pre20170225-nostrip.patch61
5 files changed, 190 insertions, 0 deletions
diff --git a/app-editors/qemacs/files/qemacs-0.4.1_pre20150916-Makefile.patch b/app-editors/qemacs/files/qemacs-0.4.1_pre20150916-Makefile.patch
new file mode 100644
index 000000000000..53c71f21580d
--- /dev/null
+++ b/app-editors/qemacs/files/qemacs-0.4.1_pre20150916-Makefile.patch
@@ -0,0 +1,38 @@
+Removes forced march setting and align-functions on x86, as they would
+override user's CFLAGS.
+
+--- qemacs-orig/Makefile
++++ qemacs/Makefile
+@@ -29,32 +29,6 @@
+ cmd :=
+ endif
+
+-ifeq ($(CC),gcc)
+- CFLAGS += -Wall -g -O2 -funsigned-char
+- # do not warn about zero-length formats.
+- CFLAGS += -Wno-format-zero-length
+- LDFLAGS := -g
+-endif
+-
+-#include local compiler configuration file
+--include $(DEPTH)/cflags.mk
+-
+-ifdef TARGET_GPROF
+- CFLAGS += -p
+- LDFLAGS += -p
+-endif
+-
+-TLDFLAGS := $(LDFLAGS)
+-
+-ifdef TARGET_ARCH_X86
+- #CFLAGS+=-fomit-frame-pointer
+- ifeq ($(GCC_MAJOR),2)
+- CFLAGS+=-m386 -malign-functions=0
+- else
+- CFLAGS+=-march=i386 -falign-functions=0
+- endif
+-endif
+-
+ DEFINES=-DHAVE_QE_CONFIG_H
+
+ ########################################################
diff --git a/app-editors/qemacs/files/qemacs-0.4.1_pre20150916-nostrip.patch b/app-editors/qemacs/files/qemacs-0.4.1_pre20150916-nostrip.patch
new file mode 100644
index 000000000000..2ee40c6d2fdb
--- /dev/null
+++ b/app-editors/qemacs/files/qemacs-0.4.1_pre20150916-nostrip.patch
@@ -0,0 +1,38 @@
+Suppress stripping.
+
+--- qemacs-orig/Makefile
++++ qemacs/Makefile
+@@ -168,7 +168,6 @@
+ qe$(EXE): qe_g$(EXE) Makefile
+ @rm -f $@
+ cp $< $@
+- -$(STRIP) $@
+ @ls -l $@
+ @echo `size $@` `wc -c $@` qe $(OPTIONS) \
+ | cut -d ' ' -f 7-10,13,15-40 >> STATS
+@@ -183,7 +182,6 @@
+ tqe$(EXE): tqe_g$(EXE) Makefile
+ @rm -f $@
+ cp $< $@
+- -$(STRIP) $@
+ @ls -l $@
+ @echo `size $@` `wc -c $@` tqe $(OPTIONS) \
+ | cut -d ' ' -f 7-10,13,15-40 >> STATS
+@@ -386,7 +384,7 @@
+ $(INSTALL) -m 755 -d $(DESTDIR)$(prefix)/bin
+ $(INSTALL) -m 755 -d $(DESTDIR)$(mandir)/man1
+ $(INSTALL) -m 755 -d $(DESTDIR)$(datadir)/qe
+- $(INSTALL) -m 755 -s qe$(EXE) $(DESTDIR)$(prefix)/bin/qemacs$(EXE)
++ $(INSTALL) -m 755 qe$(EXE) $(DESTDIR)$(prefix)/bin/qemacs$(EXE)
+ ln -sf qemacs $(DESTDIR)$(prefix)/bin/qe$(EXE)
+ ifdef CONFIG_FFMPEG
+ ln -sf qemacs$(EXE) $(DESTDIR)$(prefix)/bin/ffplay$(EXE)
+@@ -394,7 +392,7 @@
+ $(INSTALL) -m 644 kmaps ligatures $(DESTDIR)$(datadir)/qe
+ $(INSTALL) -m 644 qe.1 $(DESTDIR)$(mandir)/man1
+ ifdef CONFIG_HTML
+- $(INSTALL) -m 755 -s html2png$(EXE) $(DESTDIR)$(prefix)/bin
++ $(INSTALL) -m 755 html2png$(EXE) $(DESTDIR)$(prefix)/bin
+ endif
+
+ uninstall:
diff --git a/app-editors/qemacs/files/qemacs-0.4.1_pre20170225-Makefile.patch b/app-editors/qemacs/files/qemacs-0.4.1_pre20170225-Makefile.patch
new file mode 100644
index 000000000000..0540bcd767c4
--- /dev/null
+++ b/app-editors/qemacs/files/qemacs-0.4.1_pre20170225-Makefile.patch
@@ -0,0 +1,42 @@
+Removes forced march setting and align-functions on x86, as they would
+override user's CFLAGS.
+
+--- qemacs-orig/Makefile
++++ qemacs/Makefile
+@@ -29,35 +29,11 @@
+ cmd :=
+ endif
+
+-ifeq ($(CC),gcc)
+- CFLAGS += -Wall -g -O2 -funsigned-char
+- # do not warn about zero-length formats.
+- CFLAGS += -Wno-format-zero-length
+- LDFLAGS += -g
+-endif
+-
+-#include local compiler configuration file
+--include $(DEPTH)/cflags.mk
+-
+-ifdef TARGET_GPROF
+- CFLAGS += -p
+- LDFLAGS += -p
+-endif
+-
+ #TCFLAGS := -DCONFIG_TINY -m32 $(CFLAGS) -Os
+ #TLDFLAGS := -m32 $(LDFLAGS)
+-TCFLAGS := -DCONFIG_TINY $(CFLAGS) -Os
++TCFLAGS := -DCONFIG_TINY $(CFLAGS)
+ TLDFLAGS := $(LDFLAGS)
+
+-ifdef TARGET_ARCH_X86
+- #CFLAGS+=-fomit-frame-pointer
+- ifeq ($(GCC_MAJOR),2)
+- CFLAGS += -m386 -malign-functions=0
+- else
+- CFLAGS += -march=i386 -falign-functions=0
+- endif
+-endif
+-
+ DEFINES=-DHAVE_QE_CONFIG_H
+
+ ########################################################
diff --git a/app-editors/qemacs/files/qemacs-0.4.1_pre20170225-manpage.patch b/app-editors/qemacs/files/qemacs-0.4.1_pre20170225-manpage.patch
new file mode 100644
index 000000000000..b73f3ee356b2
--- /dev/null
+++ b/app-editors/qemacs/files/qemacs-0.4.1_pre20170225-manpage.patch
@@ -0,0 +1,11 @@
+--- qemacs-orig/qe.1
++++ qemacs/qe.1
+@@ -44,7 +44,7 @@
+ anti aliased font display.
+ .PP
+ For more information and a list of key bindings please see
+-/usr/share/doc/qemacs/README.gz.
++the README file in /usr/share/doc/@PF@/.
+ .SH AUTHOR
+ This manual page was written by Edmund GRIMLEY EVANS <edmundo@rano.org>,
+ for the Debian GNU/Linux system (but may be used by others).
diff --git a/app-editors/qemacs/files/qemacs-0.4.1_pre20170225-nostrip.patch b/app-editors/qemacs/files/qemacs-0.4.1_pre20170225-nostrip.patch
new file mode 100644
index 000000000000..60519dca5c36
--- /dev/null
+++ b/app-editors/qemacs/files/qemacs-0.4.1_pre20170225-nostrip.patch
@@ -0,0 +1,61 @@
+Suppress stripping.
+
+--- qemacs-orig/Makefile
++++ qemacs/Makefile
+@@ -203,7 +203,6 @@
+ qe$(EXE): qe_g$(EXE) Makefile
+ @rm -f $@
+ cp $< $@
+- -$(STRIP) $@
+ @ls -l $@
+ @echo `size $@` `wc -c $@` qe $(OPTIONS) \
+ | cut -d ' ' -f 7-10,13,15-40 >> STATS
+@@ -218,7 +217,6 @@
+ xqe$(EXE): xqe_g$(EXE) Makefile
+ @rm -f $@
+ cp $< $@
+- -$(STRIP) $@
+ @ls -l $@
+ @echo `size $@` `wc -c $@` xqe $(OPTIONS) \
+ | cut -d ' ' -f 7-10,13,15-40 >> STATS
+@@ -233,7 +231,6 @@
+ tqe$(EXE): tqe_g$(EXE) Makefile
+ @rm -f $@
+ cp $< $@
+- -$(STRIP) $@
+ @ls -l $@
+ @echo `size $@` `wc -c $@` tqe $(OPTIONS) \
+ | cut -d ' ' -f 7-10,13,15-40 >> STATS
+@@ -245,7 +242,6 @@
+ t1qe$(EXE): t1qe_g$(EXE) Makefile
+ @rm -f $@
+ cp $< $@
+- -$(STRIP) $@
+ @ls -l $@
+ @echo `size $@` `wc -c $@` t1qe $(OPTIONS) \
+ | cut -d ' ' -f 7-10,13,15-40 >> STATS
+@@ -478,12 +474,12 @@
+ $(INSTALL) -m 755 -d $(DESTDIR)$(mandir)/man1
+ $(INSTALL) -m 755 -d $(DESTDIR)$(datadir)/qe
+ ifdef CONFIG_X11
+- $(INSTALL) -m 755 -s xqe$(EXE) $(DESTDIR)$(prefix)/bin/qemacs$(EXE)
++ $(INSTALL) -m 755 xqe$(EXE) $(DESTDIR)$(prefix)/bin/qemacs$(EXE)
+ else
+ ifdef CONFIG_TINY
+- $(INSTALL) -m 755 -s tqe$(EXE) $(DESTDIR)$(prefix)/bin/qemacs$(EXE)
++ $(INSTALL) -m 755 tqe$(EXE) $(DESTDIR)$(prefix)/bin/qemacs$(EXE)
+ else
+- $(INSTALL) -m 755 -s qe$(EXE) $(DESTDIR)$(prefix)/bin/qemacs$(EXE)
++ $(INSTALL) -m 755 qe$(EXE) $(DESTDIR)$(prefix)/bin/qemacs$(EXE)
+ endif
+ endif
+ ln -sf qemacs$(EXE) $(DESTDIR)$(prefix)/bin/qe$(EXE)
+@@ -493,7 +489,7 @@
+ $(INSTALL) -m 644 kmaps ligatures $(DESTDIR)$(datadir)/qe
+ $(INSTALL) -m 644 qe.1 $(DESTDIR)$(mandir)/man1
+ ifdef CONFIG_HTML
+- $(INSTALL) -m 755 -s html2png$(EXE) $(DESTDIR)$(prefix)/bin
++ $(INSTALL) -m 755 html2png$(EXE) $(DESTDIR)$(prefix)/bin
+ endif
+
+ uninstall: