summaryrefslogtreecommitdiff
path: root/app-editors/hteditor/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
commitd87262dd706fec50cd150aab3e93883b6337466d (patch)
tree246b44c33ad7a57550430b0a60fa0df86a3c9e68 /app-editors/hteditor/files
parent71bc00c87bba1ce31de0dac6c3b7fd1aee6917fc (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-editors/hteditor/files')
-rw-r--r--app-editors/hteditor/files/hteditor-2.1.0-format-security.patch57
-rw-r--r--app-editors/hteditor/files/hteditor-2.1.0-gcc-6-uchar.patch45
-rw-r--r--app-editors/hteditor/files/hteditor-2.1.0-gcc-7.patch32
-rw-r--r--app-editors/hteditor/files/hteditor-2.1.0-tinfo.patch10
4 files changed, 0 insertions, 144 deletions
diff --git a/app-editors/hteditor/files/hteditor-2.1.0-format-security.patch b/app-editors/hteditor/files/hteditor-2.1.0-format-security.patch
deleted file mode 100644
index 408d1b9b1be3..000000000000
--- a/app-editors/hteditor/files/hteditor-2.1.0-format-security.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-https://bugs.gentoo.org/521018
-
-From 5839355d67ff822593190473a41512ca19e4280a Mon Sep 17 00:00:00 2001
-From: Anton Gladky <gladk@debian.org>
-Date: Wed, 18 Feb 2015 21:20:39 +0100
-Subject: [PATCH] Fix "format not a string" compilation failure
-
-Compilation with the flag -Werror=format-security fails with
-the message:
-
-error: format not a string literal and no format arguments
-
-This patch solves the issue.
----
- asm/x86dis.cc | 6 +++---
- htpal.cc | 2 +-
- 2 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/asm/x86dis.cc b/asm/x86dis.cc
-index 0830d9c..bb9028f 100644
---- a/asm/x86dis.cc
-+++ b/asm/x86dis.cc
-@@ -1218,15 +1218,15 @@ void x86dis::str_op(char *opstr, int *opstrlen, x86dis_insn *insn, x86_insn_op *
- default: {assert(0);}
- }
- if (!insn->rexprefix) {
-- sprintf(opstr, x86_regs[j][op->reg]);
-+ sprintf(opstr, "%s", x86_regs[j][op->reg]);
- } else {
-- sprintf(opstr, x86_64regs[j][op->reg]);
-+ sprintf(opstr, "%s", x86_64regs[j][op->reg]);
- }
- break;
- }
- case X86_OPTYPE_SEG:
- if (x86_segs[op->seg]) {
-- sprintf(opstr, x86_segs[op->seg]);
-+ sprintf(opstr, "%s", x86_segs[op->seg]);
- }
- break;
- case X86_OPTYPE_CRX:
-diff --git a/htpal.cc b/htpal.cc
-index 03dea18..3d5f51e 100644
---- a/htpal.cc
-+++ b/htpal.cc
-@@ -307,7 +307,7 @@ void palette_entry::strvalue(char *buf32bytes)
- text = "normal";
- }
- p = tag_make_color(p, 32, VCP(fg, bg));
-- p += sprintf(p, text);
-+ p += sprintf(p, "%s", text);
- p = tag_make_default_color(p, 32);
- *p = 0;
- }
---
-2.16.2
-
diff --git a/app-editors/hteditor/files/hteditor-2.1.0-gcc-6-uchar.patch b/app-editors/hteditor/files/hteditor-2.1.0-gcc-6-uchar.patch
deleted file mode 100644
index 67eaa6e01491..000000000000
--- a/app-editors/hteditor/files/hteditor-2.1.0-gcc-6-uchar.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-https://github.com/sebastianbiallas/ht/pull/21
-
-From 7ce68c4bca7fd64c0073f1770c6b5761c03174f0 Mon Sep 17 00:00:00 2001
-From: Sergei Trofimovich <slyfox@gentoo.org>
-Date: Wed, 21 Mar 2018 21:30:31 +0000
-Subject: [PATCH] ht: fix build failure on -funsigned-char platforms
-
-powerpc (and arm) have 'char' == 'unsigned char' by default.
-This causes build failures on c++11:
-
-```
-$ ./configure CFLAGS=-funsigned-char CXXFLAGS=-funsigned-char
-$ make
-
-g++ -DHAVE_CONFIG_H -I. -I./analyser -I./asm -I./info -I./io/posix -I./io -I./output -I./eval -I. -DNOMACROS -pipe -O3 -fomit-frame-pointer -Wall -fsigned-char -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -std=c++14 -Woverloaded-virtual -Wnon-virtual-dtor -funsigned-char -MT htcoffhd.o -MD -MP -MF .deps/htcoffhd.Tpo -c -o htcoffhd.o htcoffhd.cc
-htcoffhd.cc:93:1: error: narrowing conversion of '-1' from 'int' to 'char' inside { } [-Wnarrowing]
- };
- ^
-htcoffhd.cc:131:1: error: narrowing conversion of '-1' from 'int' to 'char' inside { } [-Wnarrowing]
- };
-```
-
-Use 'signed char' explicitly to maintain existing behavior.
-
-Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
----
- httag.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/httag.h b/httag.h
-index 7f5da1c..83e5c22 100644
---- a/httag.h
-+++ b/httag.h
-@@ -69,7 +69,7 @@ struct ht_tag_flags {
- } PACKED;
-
- struct ht_tag_flags_s {
-- char bitidx;
-+ signed char bitidx;
- const char *desc;
- } PACKED;
-
---
-2.16.2
-
diff --git a/app-editors/hteditor/files/hteditor-2.1.0-gcc-7.patch b/app-editors/hteditor/files/hteditor-2.1.0-gcc-7.patch
deleted file mode 100644
index ebcc3c0aa43e..000000000000
--- a/app-editors/hteditor/files/hteditor-2.1.0-gcc-7.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-https://bugs.gentoo.org/show_bug.cgi?id=620732
-
-Fixes build failure on gcc-7:
-
- htapp.cc: In function 'uint isqr(uint)':
- htapp.cc:3026:18: error: call of overloaded 'abs(uint)' is ambiguous
- while (abs(a - b) > 1) {
- ^
-
-Picked upstream patch that fixes it:
-
-commit 3b62f2f7e49e024ec9d3c5ffc8ff9cd87a107af6
-Author: Sebastian Biallas <sb@biallas.net>
-Date: Sun Nov 13 15:25:26 2016 +0100
-
- use unsigned variables
-
-diff --git a/htapp.cc b/htapp.cc
-index 53d8725..03236e2 100644
---- a/htapp.cc
-+++ b/htapp.cc
-@@ -3021,8 +3021,8 @@ void do_modal_resize()
-
- static uint isqr(uint u)
- {
-- uint a = 2;
-- uint b = u/a;
-+ int a = 2;
-+ int b = u/a;
- while (abs(a - b) > 1) {
- a = (a+b)/2;
- b = u/a;
diff --git a/app-editors/hteditor/files/hteditor-2.1.0-tinfo.patch b/app-editors/hteditor/files/hteditor-2.1.0-tinfo.patch
deleted file mode 100644
index 556cb93569d4..000000000000
--- a/app-editors/hteditor/files/hteditor-2.1.0-tinfo.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -198,6 +198,7 @@
- fi
- HT_LIBS="$HT_LIBS -l$CURSES_LIB"
- fi
-+AC_SEARCH_LIBS(stdscr,tinfo)
-
- dnl Makefile vars.
- AC_SUBST(IO_DIR)