summaryrefslogtreecommitdiff
path: root/app-benchmarks/pipebench/pipebench-0.40-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
commit76dfef0cec9170000357d2f354e412daf48941fc (patch)
tree56647120c0ee20ab3494475c86722034cd194b02 /app-benchmarks/pipebench/pipebench-0.40-r2.ebuild
parentccf84bcd604130256d1377cd58f0a634ae6ee20f (diff)
gentoo resync : 30.12.2017
Diffstat (limited to 'app-benchmarks/pipebench/pipebench-0.40-r2.ebuild')
-rw-r--r--app-benchmarks/pipebench/pipebench-0.40-r2.ebuild25
1 files changed, 6 insertions, 19 deletions
diff --git a/app-benchmarks/pipebench/pipebench-0.40-r2.ebuild b/app-benchmarks/pipebench/pipebench-0.40-r2.ebuild
index 610bcc5df90d..0688bd665cff 100644
--- a/app-benchmarks/pipebench/pipebench-0.40-r2.ebuild
+++ b/app-benchmarks/pipebench/pipebench-0.40-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Measures the speed of stdin/stdout communication"
HOMEPAGE="http://www.habets.pp.se/synscan/programs.php?prog=pipebench"
@@ -11,25 +11,12 @@ SRC_URI="ftp://ftp.habets.pp.se/pub/synscan/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86 ~arm-linux ~x86-linux"
+KEYWORDS="~alpha amd64 ppc ppc64 x86 ~arm-linux ~x86-linux"
IUSE=""
-src_prepare() {
- sed -i Makefile \
- -e 's:CFLAGS=-Wall:CFLAGS+= -Wall:' \
- -e 's:$(CFLAGS) -o:$(LDFLAGS) &:g' \
- -e "s:/usr/local/bin/:${ED}/usr/bin:" \
- -e "s:/usr/local/man/man1/:${ED}/usr/share/man/man1:" \
- || die "sed Makefile"
- default
-}
-
-src_compile() {
- emake CC=$(tc-getCC)
-}
+PATCHES=( "${FILESDIR}"/${PN}-0.40-fix-build-system.patch )
-src_install() {
- dodir /usr/{bin,share/man/man1}
- emake install
- dodoc README
+src_configure() {
+ append-cflags -Wall -w -pedantic
+ tc-export CC
}