summaryrefslogtreecommitdiff
path: root/app-arch/innoextract/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-arch/innoextract/files
reinit the tree, so we can have metadata
Diffstat (limited to 'app-arch/innoextract/files')
-rw-r--r--app-arch/innoextract/files/innoextract-1.4-cmake-3.5.patch31
-rw-r--r--app-arch/innoextract/files/innoextract-1.4-cmake.patch30
2 files changed, 61 insertions, 0 deletions
diff --git a/app-arch/innoextract/files/innoextract-1.4-cmake-3.5.patch b/app-arch/innoextract/files/innoextract-1.4-cmake-3.5.patch
new file mode 100644
index 000000000000..0b619ac3810f
--- /dev/null
+++ b/app-arch/innoextract/files/innoextract-1.4-cmake-3.5.patch
@@ -0,0 +1,31 @@
+From 01705758dd04d937160c99c8b87c6fa2057db894 Mon Sep 17 00:00:00 2001
+From: Daniel Scharrer <daniel@constexpr.org>
+Date: Tue, 23 Feb 2016 05:45:50 +0100
+Subject: [PATCH] CMake: Disable variable expansion for quoted strings in if()
+
+This makes the build system more rubust against stray variables
+coming from included CMake scripts provided by the system.
+
+Fixes build with CMake 3.5 (tested with 3.5.0-rc3).
+
+Fixes: issue #50
+---
+ CMakeLists.txt | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 02e0308..8653b93 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -2,6 +2,11 @@ project(innoextract)
+
+ cmake_minimum_required(VERSION 2.8)
+
++if(POLICY CMP0054)
++ # CMake 3.1+: Only interpret if() arguments as variables or keywords when unquoted.
++ cmake_policy(SET CMP0054 NEW)
++endif()
++
+
+ # Define configuration options
+
diff --git a/app-arch/innoextract/files/innoextract-1.4-cmake.patch b/app-arch/innoextract/files/innoextract-1.4-cmake.patch
new file mode 100644
index 000000000000..199a10e14fac
--- /dev/null
+++ b/app-arch/innoextract/files/innoextract-1.4-cmake.patch
@@ -0,0 +1,30 @@
+--- innoextract-1.4/CMakeLists.txt
++++ innoextract-1.4/CMakeLists.txt
+@@ -6,6 +6,7 @@
+ # Define configuration options
+
+ option(USE_LZMA "Build lzma decompression support." ON)
++option(WITH_DEBUG "Debug build" OFF)
+ option(DEBUG_EXTRA "Expensive debug options" OFF)
+ option(SET_WARNING_FLAGS "Adjust compiler warning flags" ON)
+ option(SET_OPTIMIZATION_FLAGS "Adjust compiler optimization flags" ON)
+--- innoextract-1.4/cmake/BuildType.cmake
++++ innoextract-1.4/cmake/BuildType.cmake
+@@ -8,7 +8,7 @@
+ if(CMAKE_BUILD_TYPE STREQUAL "")
+ set(CMAKE_BUILD_TYPE "Release")
+ endif()
+-if(CMAKE_BUILD_TYPE STREQUAL "Debug")
++if(CMAKE_BUILD_TYPE STREQUAL "Debug" OR WITH_DEBUG)
+ add_definitions(-DDEBUG)
+ set(DEBUG 1)
+ endif()
+@@ -64,7 +64,7 @@
+ # Specifically, the need for libboost_system depends on the Boost version
+ add_ldflag("-Wl,--as-needed")
+
+- if(CMAKE_BUILD_TYPE STREQUAL "Debug")
++ if(CMAKE_BUILD_TYPE STREQUAL "Debug" OR WITH_DEBUG)
+
+ # set debug symbol level to -g3
+ check_compiler_flag(RESULT "-g3")