summaryrefslogtreecommitdiff
path: root/app-arch/engrampa
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-15 11:48:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-15 11:48:08 +0100
commit04fc7f10cec12efb1240344a0090b539e24ad0f3 (patch)
tree130fb059a6b83e95af28b97b0f55c716d48924bf /app-arch/engrampa
parent0bec4ab1937eed98ee24e2d48f0cfec46de2fc58 (diff)
gentoo auto-resync : 15:04:2023 - 11:48:08
Diffstat (limited to 'app-arch/engrampa')
-rw-r--r--app-arch/engrampa/Manifest3
-rw-r--r--app-arch/engrampa/engrampa-1.26.0-r1.ebuild (renamed from app-arch/engrampa/engrampa-1.26.0.ebuild)6
-rw-r--r--app-arch/engrampa/files/engrampa-1.26.0-clang16.patch24
3 files changed, 31 insertions, 2 deletions
diff --git a/app-arch/engrampa/Manifest b/app-arch/engrampa/Manifest
index 74097e5642b6..4e78d5599273 100644
--- a/app-arch/engrampa/Manifest
+++ b/app-arch/engrampa/Manifest
@@ -1,3 +1,4 @@
+AUX engrampa-1.26.0-clang16.patch 700 BLAKE2B f737fb50695275afc0e0a148bbfcc72ff33251fd506823d107880883e90a9c28404fc937f7752ee065bc07bcde3507321469b6ee3f0e11e9c6c4912e705aca7c SHA512 c2086e26e65005916cecbb89392eba9090d8a8c02181878735fc7ed05996fe6cf7149bac3fc08cafb63814123620fb7237d1d859007df0ee4490b61ae1581951
DIST engrampa-1.26.0.tar.xz 1761596 BLAKE2B c72def523f6589ab97351568e0562898d996e640ffefa66f32096e5a0ad97ad0b05b21ebdcc16ba1f75d9b75a444f8ed4ed492a412cc16c018e65135a88f3398 SHA512 8058627af19744d26f0997fca37a9a1d9902c63e4008e1af44b2a3b15ebc03e27f2018c60351ee503a28aa072836d201625074abb838e0a95071ce65c64a52bc
-EBUILD engrampa-1.26.0.ebuild 1766 BLAKE2B 2d1376207cf3fc009deb0db8c7f3bc2e08976c187cdfdbae0000ba169a0763d2e1ab1e1f68cb070d9753ef8e2bc65f27d54491aae33f8d26e9f00357dff7c933 SHA512 5c5e8b800bc886f65f20b426a3abe257b1f014e37f43c14beb230d09121c15ea986bea16681244e50fce76224c2bbca5ce8d608dd0b166fa36a61b65ab7004aa
+EBUILD engrampa-1.26.0-r1.ebuild 1821 BLAKE2B a7b2964900bdb27a319164580b95ff27ab3cb1450d57710f15932fd8f8e51729316474abb00b045c86db4b98fe6cd770fc712464b9929e2035b32fc2e0130bc5 SHA512 2228f66f0dca58ce06b5d53bca511cd4c912d39f5c55fd2e14a1edcaded3f94909a54e06eaa5a04608864dd89c27085bc69fd7d6f8432249b85666fbadf88058
MISC metadata.xml 488 BLAKE2B 94c92acef521db2b65cf3cfe1d28cf20de16ea9546a64554450d3cf9c95deb5863fa0880b7009e8501401736a39c2bde2e86bd4e848f40d565f0a07d5b4a6745 SHA512 c50ee7773f9c81653b7248f7187cf379312a3a36e89a7093840e43f89f8cc3a96cdfa91b1f29a51def525226349bfdc66d5bc028ffed80c7b778c7687feef1ce
diff --git a/app-arch/engrampa/engrampa-1.26.0.ebuild b/app-arch/engrampa/engrampa-1.26.0-r1.ebuild
index 82d52bffe28c..3d8bd7013852 100644
--- a/app-arch/engrampa/engrampa-1.26.0.ebuild
+++ b/app-arch/engrampa/engrampa-1.26.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -42,6 +42,10 @@ BDEPEND="
virtual/pkgconfig
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.26.0-clang16.patch
+)
+
src_configure() {
mate_src_configure \
--disable-run-in-place \
diff --git a/app-arch/engrampa/files/engrampa-1.26.0-clang16.patch b/app-arch/engrampa/files/engrampa-1.26.0-clang16.patch
new file mode 100644
index 000000000000..334987a40baf
--- /dev/null
+++ b/app-arch/engrampa/files/engrampa-1.26.0-clang16.patch
@@ -0,0 +1,24 @@
+https://bugs.gentoo.org/875404
+https://github.com/mate-desktop/engrampa/pull/477
+
+From f54425f1f994fc235c6cdd4013eb9fcf17da9f29 Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Fri, 14 Apr 2023 22:35:08 +0200
+Subject: [PATCH] file-utils: Include <strings.h> for strcasecmp
+
+The _XOPEN_SOURCE macro definition overrides _DEFAULT_SOURCE
+and disables the declaration in <string.h>.
+
+This avoids an implicit function declaration and build failures
+with future compilers.
+--- a/src/file-utils.c
++++ b/src/file-utils.c
+@@ -27,6 +27,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
++#include <strings.h>
+ #include <ctype.h>
+ #include <time.h>
+ #include <unistd.h>
+