summaryrefslogtreecommitdiff
path: root/app-admin/gixy/gixy-0.1.20.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /app-admin/gixy/gixy-0.1.20.ebuild
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'app-admin/gixy/gixy-0.1.20.ebuild')
-rw-r--r--app-admin/gixy/gixy-0.1.20.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-admin/gixy/gixy-0.1.20.ebuild b/app-admin/gixy/gixy-0.1.20.ebuild
new file mode 100644
index 000000000000..d56ff0091eef
--- /dev/null
+++ b/app-admin/gixy/gixy-0.1.20.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Nginx configuration static analyzer"
+HOMEPAGE="https://github.com/yandex/gixy"
+# Use GitHub source insted PyPi to get tarball with tests
+SRC_URI="https://github.com/yandex/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/pyparsing-1.5.5[${PYTHON_USEDEP}]
+ >=dev-python/cached-property-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/configargparse-0.11.0[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.8[${PYTHON_USEDEP}]
+ >=dev-python/six-1.1.0[${PYTHON_USEDEP}]"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ ${RDEPEND}
+ )
+"
+
+python_prepare() {
+ sed -i -e "/argparse/d" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v || die
+}